Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


Skip to content

Matrix (Synapse/Element)

97 Topics 1.1k Posts
  • Matrix (Synapse/Element) - Package Updates

    Pinned
    282
    0 Votes
    282 Posts
    26k Views
    girishG

    [1.94.0]

    Update Synapse to 1.108.0 Full changelog Add a feature that allows clients to query the configured federation whitelist. Disabled by default. (#16848, #17199) Add the ability to allow numeric user IDs with a specific prefix when in the CAS flow. Contributed by Aurélien Grimpard. (#17098) Fix bug where push rules would be empty in /sync for some accounts. Introduced in v1.93.0. (#17142) Add support for optional whitespace around the Federation API's Authorization header's parameter commas. (#17145) Fix bug where disabling room publication prevented public rooms being created on workers. (#17177, #17184)
  • Matrix/Synapse Admin Interface

    23
    0 Votes
    23 Posts
    6k Views
    L

    Just uploaded and extracted latest version but it's just loading, don't see any login screen

  • Can't get admin-ui running

    Unsolved
    7
    1 Votes
    7 Posts
    79 Views
    girishG

    @compotter I used the File manager instead of the Surfer admin (since surfer admin UI does not support extract yet). But after extract and moving , I had to move the files one level up. It should look like this:

    image.png

  • Matrix in constant "starting..." state.

    7
    1 Votes
    7 Posts
    170 Views
    girishG

    @gargamel8 ok, there are some suggested solutions at https://docs.cloudron.io/troubleshooting/#hairpin-nat . Maybe something works for you.

  • 1 Votes
    9 Posts
    143 Views
    D

    This is very interesting @jdaviescoates thank you for this. I'll examinate this more deeply !

  • Matrix "Not responding" after automatic Update from v1.82.0 to v1.83.0

    Moved
    16
    0 Votes
    16 Posts
    261 Views
    R

    @girish
    Thanks for the tip, I have entered pfSense as DNS, now it works again.

    At the end of last week I set up a test server to play with which is connected to a different firewall. I had exactly the same problem with this fresh installation.

    Another problem with the new login procedure is that mobile devices with the policy of not allowing cookies can no longer log in to the Element app.
    An alternative solution must now be found, possibly deactivating openID if this is possible, but that is another topic.

    Many thanks for your help and have a good week!

    For all those who need a short summary:

    Log in via SSH
    Create the file "custom.conf":

    sudo touch /etc/unbound/unbound.conf.d/custom.conf

    Edit file:

    sudo nano /etc/unbound/unbound.conf.d/custom.conf

    Insert content into the file:

    # this disables DNSSEC server: val-permissive-mode: yes # forward all queries to the internal DNS forward-zone: name: "." forward-addr: 172.xxx.xxx.xxx

    Restart:

    sudo systemctl restart unbound

    Check:

    sudo systemctl status unbound
  • Matrix Healtheck error: Error: Timeout of 7000ms exceeded

    Solved
    5
    0 Votes
    5 Posts
    160 Views
    archosA

    So for two days, it looks like everything's fine. I think I can close this thread.

  • Questions to Matrix

    3
    0 Votes
    3 Posts
    144 Views
    L

    @nebulon said in Questions to Matrix:

    There is already a thread for file uploads at https://forum.cloudron.io/topic/11032/unable-to-increase-upload-size-above-2gb-matrix/21

    Thank you, then we I have to wait for an update because I use only E2E rooms

  • Element Starter Core

    2
    2 Votes
    2 Posts
    188 Views
    M

    News: https://element.io/blog/2024-is-about-being-in-your-element/

  • Unable to increase upload size above 2GB Matrix

    Moved
    21
    0 Votes
    21 Posts
    563 Views
    M

    Found a solution in the old bug report, only issue is that it doesn't work in e2e rooms
    here is the solution https://github.com/matrix-org/synapse/issues/12023#issuecomment-1044337550

    That seemed to work because when uploading to an unencrypted room the upload does start, but when uploading in a e2e room it just failed (doesn't even start uploading) Does anyone have an idea on how we can make this work in e2e rooms as well?

    btw for anyone trying to apply it do the following
    1, go to the terminal. 2, click postgress then type psql and press enter.
    3, paste in the following to change media_length from integer to bigint

    ALTER TABLE local_media_repository ALTER COLUMN media_length TYPE bigint;

    you can use the following to check if the change was applied

    SELECT data_type FROM information_schema.columns WHERE table_name = 'local_media_repository' AND column_name = 'media_length';
  • Expand Matrix app features

    26
    13 Votes
    26 Posts
    2k Views
    andreasduerenA

    @girish said in Expand Matrix app features:

    @Sam_uk are you looking for a specific connector? I think adding all of them is not going to be "sustainable". It's just going to break with all releases and dependencies.

    For me it's really only the WhatsApp bridge. It's by far the most popular chat service, requires no API access with a complex registration process or high fees and is fairly easy to use. I am basically currently running a separate server with yunohost just so I can use the bridge and would love to change that.

  • Matrix Homeserver Sliding Sync

    11
    7 Votes
    11 Posts
    2k Views
    jdaviescoatesJ

    @r369 said in Matrix Homeserver Sliding Sync:

    it was ages since it was out

    Not really. It's hasn't hit 1.0 yet and is still considered unstable afaict. It's not yet a standard part of Matrix.

  • Matrix Synapse on Home PC

    Solved
    6
    0 Votes
    6 Posts
    119 Views
    L

    Just an small update, moving my cloudron from VPS to my Intel NUC went very smooth, thank you @girish and @nebulon for your great work 🙂

  • Domain misconfiguration

    11
    0 Votes
    11 Posts
    342 Views
    potemkin_aiP

    I understand the rationale, thanks.

    But the current decision have the following disadvantages, from what I see:

    it ignores my settings - I'm asked at which domain I would like Synapse to be installed and then I get it on my root domain, regardless my input - I've spend quite a time to figure that out you are dependant on the ever growing list of new domains

    What we discuss calls delegation in Synapse terminology. It feels like extra feature for me and I really can't see reason to keep in on Cloudron, at least not with current setup.

    Just in case - I know how to make things working for me, so I would be just fine with things as is, but I believe it's wrong from the logical perspective.

  • Official Cloudron matrix room(s)

    Solved
    8
    1 Votes
    8 Posts
    295 Views
    girishG

    @lukas it's not very active. We mostly stick to the forum since this is publicly indexable.

  • Change Domain Matrix/Element

    Moved
    12
    0 Votes
    12 Posts
    714 Views
    scookeS

    @girish Oops! My mistake!

  • high CPU usage on Synapse

    4
    0 Votes
    4 Posts
    203 Views
    D

    Hi,
    in logs I can find nothing, federation is off.
    I had a look at the website and add to homeserver.yaml:
    caches:
    global_factor: 2.0
    per_cache_factors:
    get_users_who_share_room_with_user: 2.0
    sync_response_cache_duration: 4m
    cache_autotuning:
    max_cache_memory_usage: 4096M
    target_cache_memory_usage: 1516M
    min_cache_ttl: 30m

    Then I deleted approx. 400 unused rooms, but nothing helps.
    I guess it is related to presence. There are 186 users, not too much.

    Maybe we move Matrix/Element to separate hardware.

    greetings
    dirk

  • Why does matrix docker not open ports needed for turn server?

    Solved
    21
    0 Votes
    21 Posts
    476 Views
    nebulonN

    In this case I meant https://en.wikipedia.org/wiki/Interactive_Connectivity_Establishment

  • OIDC migration

    13
    1 Votes
    13 Posts
    438 Views
    potemkin_aiP

    As a side note: Cloudron's SSO completely ignores whitelabeling settings.

  • federation tester not working on base domain

    Solved
    10
    0 Votes
    10 Posts
    295 Views
    RazielKanosR

    ok, got it fixed...
    Cloudron told me to:

    For federation to work, the delegation URI https://domain.com/.well-known/matrix/server must be configured. See the docs on how to do this.

    but to get it working, I had to add:
    matrix.domain.com:443

    Topic can be marked as solved 🙂