<?xml version="1.0" encoding="UTF-8"?><rss xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:atom="http://www.w3.org/2005/Atom" version="2.0"><channel><title><![CDATA[Move Data failed: "Error : Inactive - Error getting IP of postgresql service"]]></title><description><![CDATA[<h1>Description</h1>
<p dir="auto">I just tried to "Move Data" for a Linkding install on Linode, and I got:</p>
<blockquote>
<p dir="auto">Error : Inactive - Error getting IP of postgresql service</p>
</blockquote>
<h2>Logs</h2>
<pre><code>Oct 14 19:14:36 box:taskworker Starting task 359. Logs are at /home/yellowtent/platformdata/logs/xxx-yyy-zzz/apptask.log
Oct 14 19:14:36 box:taskworker Running task of type app
Oct 14 19:14:36 box:apptask run: startTask installationState: pending_data_dir_migration runState: stopped
Oct 14 19:14:36 box:tasks update 359: {"percent":10,"message":"Deleting old containers"}
Oct 14 19:14:36 box:apptask deleteContainer: deleting app containers (app, scheduler)
Oct 14 19:14:36 box:shell apptask /usr/bin/sudo -S /home/yellowtent/box/src/scripts/configurelogrotate.sh remove xxx-yyy-zzz
Oct 14 19:14:36 box:tasks update 359: {"percent":45,"message":"Ensuring app data directory"}
Oct 14 19:14:36 box:tasks update 359: {"percent":50,"message":"Setting up addons"}
Oct 14 19:14:36 box:services setupAddons: Setting up ["localstorage","postgresql","oidc"]
Oct 14 19:14:36 box:services setupAddons: setting up addon localstorage with options {}
Oct 14 19:14:36 box:services setupLocalStorage
Oct 14 19:14:36 box:shell services /usr/bin/sudo -S /home/yellowtent/box/src/scripts/mkdirvolume.sh /home/yellowtent/appsdata/xxx-yyy-zzz/data
Oct 14 19:14:36 box:services Setting up postgresql
Oct 14 19:14:36 box:services setupAddons: setting up addon postgresql with options {}
Oct 14 19:14:36 box:apptask run: app error for state pending_data_dir_migration: BoxError: Error getting IP of postgresql service at getContainerDetails (/home/yellowtent/box/src/services.js:310:20) at process.processTicksAndRejections (node:internal/process/task_queues:95:5) at async Object.setupPostgreSql [as setup] (/home/yellowtent/box/src/services.js:1495:20) at async Object.setupAddons (/home/yellowtent/box/src/services.js:621:9) at async migrateDataDir (/home/yellowtent/box/src/apptask.js:542:5) { reason: 'Inactive', details: {} }
Oct 14 19:14:36 box:tasks setCompleted - 359: {"result":null,"error":{"stack":"BoxError: Error getting IP of postgresql service\n at getContainerDetails (/home/yellowtent/box/src/services.js:310:20)\n at process.processTicksAndRejections (node:internal/process/task_queues:95:5)\n at async Object.setupPostgreSql [as setup] (/home/yellowtent/box/src/services.js:1495:20)\n at async Object.setupAddons (/home/yellowtent/box/src/services.js:621:9)\n at async migrateDataDir (/home/yellowtent/box/src/apptask.js:542:5)","name":"BoxError","reason":"Inactive","details":{},"message":"Error getting IP of postgresql service"}}
Oct 14 19:14:36 box:tasks update 359: {"percent":100,"result":null,"error":{"stack":"BoxError: Error getting IP of postgresql service\n at getContainerDetails (/home/yellowtent/box/src/services.js:310:20)\n at process.processTicksAndRejections (node:internal/process/task_queues:95:5)\n at async Object.setupPostgreSql [as setup] (/home/yellowtent/box/src/services.js:1495:20)\n at async Object.setupAddons (/home/yellowtent/box/src/services.js:621:9)\n at async migrateDataDir (/home/yellowtent/box/src/apptask.js:542:5)","name":"BoxError","reason":"Inactive","details":{},"message":"Error getting IP of postgresql service"}}
Oct 14 19:14:36 box:taskworker Task took 0.155 seconds
Oct 14 19:14:36 BoxError: Error getting IP of postgresql service
Oct 14 19:14:36 BoxError: Error getting IP of postgresql service
Oct 14 19:14:36 BoxError: Error getting IP of postgresql service
Oct 14 19:14:36 BoxError: Error getting IP of postgresql service
</code></pre>
<h2>Troubleshooting Already Performed</h2>
<p dir="auto">I've tried restarting, re-trying the task. I installed postgresql on my Linode box, even though it's never been needed before.</p>
<h1>System Details</h1>
<h2>Generate Diagnostics Data</h2>
<h2>Cloudron Version</h2>
<pre><code>8.3.2
</code></pre>
<h2>Ubuntu Version</h2>
<pre><code>No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 24.04.2 LTS
Release:	24.04
Codename:	noble
</code></pre>
<h2>Cloudron installation method</h2>
<pre><code>Manual with `./cloudron-setup`
</code></pre>
<h2>Output of <code>cloudron-support --troubleshoot</code></h2>
<pre><code>Vendor: Linode Product: Compute Instance
Linux: 6.8.0-79-generic
Ubuntu: noble 24.04
Processor: AMD EPYC 7713 64-Core Processor
BIOS pc-q35-7.2  CPU @ 2.0GHz x 1
RAM: 2015320KB
Disk: /dev/sda        7.8G
[OK]	node version is correct
[OK]	IPv6 is enabled and public IPv6 address is working
[OK]	docker is running
[OK]	docker version is correct
[OK]	MySQL is running
[OK]	nginx is running
[OK]	dashboard cert is valid
[OK]	dashboard is reachable via loopback
[OK]	box v8.3.2 is running
[WARN]	netplan configuration is empty. this might be OK depending on your networking setup
[OK]	DNS is resolving via systemd-resolved
[OK]	Dashboard is reachable via domain name
[WARN]	Domain example.com expiry check skipped because whois does not have this information
[OK]	unbound is running
</code></pre>
]]></description><link>https://forum.cloudron.io/topic/14411/move-data-failed-error-inactive-error-getting-ip-of-postgresql-service</link><generator>RSS for Node</generator><lastBuildDate>Thu, 10 Sep 2026 12:43:47 GMT</lastBuildDate><atom:link href="https://forum.cloudron.io/topic/14411.rss" rel="self" type="application/rss+xml"/><pubDate>Tue, 14 Oct 2025 23:27:41 GMT</pubDate><ttl>60</ttl><item><title><![CDATA[Reply to Move Data failed: "Error : Inactive - Error getting IP of postgresql service" on Thu, 16 Oct 2025 17:08:35 GMT]]></title><description><![CDATA[<p dir="auto">Thanks <a class="plugin-mentions-user plugin-mentions-a" href="/user/james" aria-label="Profile: james">@<bdi>james</bdi></a> -- yes, this is solved.</p>
]]></description><link>https://forum.cloudron.io/post/113922</link><guid isPermaLink="true">https://forum.cloudron.io/post/113922</guid><dc:creator><![CDATA[jsit]]></dc:creator><pubDate>Thu, 16 Oct 2025 17:08:35 GMT</pubDate></item><item><title><![CDATA[Reply to Move Data failed: "Error : Inactive - Error getting IP of postgresql service" on Wed, 15 Oct 2025 12:11:54 GMT]]></title><description><![CDATA[<p dir="auto">Hello <a class="plugin-mentions-user plugin-mentions-a" href="/user/jsit" aria-label="Profile: jsit">@<bdi>jsit</bdi></a><br />
Can I take your post here <a href="https://forum.cloudron.io/post/113824">https://forum.cloudron.io/post/113824</a> as you solved this issue now?</p>
]]></description><link>https://forum.cloudron.io/post/113830</link><guid isPermaLink="true">https://forum.cloudron.io/post/113830</guid><dc:creator><![CDATA[james]]></dc:creator><pubDate>Wed, 15 Oct 2025 12:11:54 GMT</pubDate></item><item><title><![CDATA[Reply to Move Data failed: "Error : Inactive - Error getting IP of postgresql service" on Wed, 15 Oct 2025 12:01:57 GMT]]></title><description><![CDATA[<p dir="auto">Hello <a class="plugin-mentions-user plugin-mentions-a" href="/user/jsit" aria-label="Profile: jsit">@<bdi>jsit</bdi></a> and welcome to the Cloudron Forum</p>
<p dir="auto"><a class="plugin-mentions-user plugin-mentions-a" href="/user/jsit" aria-label="Profile: jsit">@<bdi>jsit</bdi></a> said in <a href="/post/113823">Move Data failed: "Error : Inactive - Error getting IP of postgresql service"</a>:</p>
<blockquote>
<p dir="auto">I installed postgresql on my Linode box</p>
</blockquote>
<p dir="auto">You should never install anything alongside Cloudron, unless you know exactly what you are doing and can fix issues yourself.<br />
The underlaying system should only be touched if you are told by Cloudron, the Cloudron Support or here in the forum.</p>
<p dir="auto">You might have caused irreversible damage to your Cloudron System.<br />
I strongly advice to restore Cloudron from the latest backup.</p>
<p dir="auto">Please see: <a href="https://docs.cloudron.io/backups/#restore-cloudron" target="_blank" rel="noopener noreferrer nofollow ugc">https://docs.cloudron.io/backups/#restore-cloudron</a></p>
]]></description><link>https://forum.cloudron.io/post/113827</link><guid isPermaLink="true">https://forum.cloudron.io/post/113827</guid><dc:creator><![CDATA[james]]></dc:creator><pubDate>Wed, 15 Oct 2025 12:01:57 GMT</pubDate></item></channel></rss>