<?xml version="1.0" encoding="UTF-8"?><rss xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:atom="http://www.w3.org/2005/Atom" version="2.0"><channel><title><![CDATA[Wordpress upgrading, but not starting, due to missing Redis info]]></title><description><![CDATA[<p dir="auto">It seems Wordpress is also missing the Cloudron SSO plugin? Cloudron is 9.2, on Ubuntu 22 (server deets below). Wordpress itself has been updating from low 3.15s to the current 3.16 fine, it just won't start. I checked the credentials.txt and this is the Redis entry at the bottom:</p>
<pre><code>Redis Credentials
=================

Hostname: NA
Port:     NA
Password: NA
</code></pre>
<p dir="auto">I'm pretty sure I turned off or deleted that Redis option anyway, and in Services for the Cloudron it does only show one Redis for another app, but not for this one. The question is I guess, how do I edit what to fix this so it can start!? Thank you!</p>
<pre><code>Sep 26 08:30:59 =&gt; Updating redis settings
Sep 26 08:31:00 =&gt; Healthcheck error: Error: connect ECONNREFUSED 172.18.19.133:80
Sep 26 08:31:07 Warning: The 'redis-cache' plugin could not be found.
Sep 26 08:31:07 Error: No plugins deactivated.
Sep 26 08:31:10 =&gt; Healthcheck error: Error: connect ECONNREFUSED 172.18.19.133:80
Sep 26 08:31:11 Warning: The 'redis-cache' plugin could not be found.
Sep 26 08:31:11 Error: No plugins uninstalled.
Sep 26 08:31:13 Error: The constant or variable 'WP_REDIS_HOST' is not defined in the 'wp-config.php' file.
Sep 26 08:31:14 Error: The constant or variable 'WP_REDIS_PORT' is not defined in the 'wp-config.php' file.
Sep 26 08:31:15 Error: The constant or variable 'WP_REDIS_PASSWORD' is not defined in the 'wp-config.php' file.
Sep 26 08:31:19 =&gt; Updating domain related settings
Sep 26 08:31:20 =&gt; Healthcheck error: Error: connect ECONNREFUSED 172.18.19.133:80
Sep 26 08:31:20 Success: Updated the constant 'WP_HOME' in the 'wp-config.php' file with the value 'https://futurnumerique.com'.
Sep 26 08:31:22 Success: Updated the constant 'WP_SITEURL' in the 'wp-config.php' file with the value 'https://futurnumerique.com'.
Sep 26 08:31:26 Success: Value passed for 'siteurl' option is unchanged.
Sep 26 08:31:29 Success: Value passed for 'home' option is unchanged.
Sep 26 08:31:30 =&gt; Healthcheck error: Error: connect ECONNREFUSED 172.18.19.133:80
Sep 26 08:31:33 =&gt; Install smtp mail plugin
Sep 26 08:31:39 Plugin 'smtp-mailer' activated.
Sep 26 08:31:39 Success: Activated 1 of 1 plugins.
Sep 26 08:31:39 =&gt; Configuring smtp-mailer plugin
Sep 26 08:31:40 =&gt; Healthcheck error: Error: connect ECONNREFUSED 172.18.19.133:80
Sep 26 08:31:43 ==&gt; Configuring smtp-mailer plugin for https://futurnumerique.com
Sep 26 08:31:49 Success: Value passed for 'smtp_mailer_options' option is unchanged.
Sep 26 08:31:49 =&gt; Creating credentials.txt
Sep 26 08:31:50 =&gt; Healthcheck error: Error: connect ECONNREFUSED 172.18.19.133:80
Sep 26 08:32:00 =&gt; Healthcheck error: Error: connect ECONNREFUSED 172.18.19.133:80
Sep 26 08:32:02 Plugin 'daggerhart-openid-connect-generic' activated.
Sep 26 08:32:02 Success: Activated 1 of 1 plugins.
Sep 26 08:32:05 Unpacking the package...
Sep 26 08:32:05 Installing the plugin...
Sep 26 08:32:05 Removing the old version of the plugin...
Sep 26 08:32:06 Plugin updated successfully.
Sep 26 08:32:09 Success: Installed 1 of 1 plugins.
Sep 26 08:32:10 =&gt; Healthcheck error: Error: connect ECONNREFUSED 172.18.19.133:80
Sep 26 08:32:13 Warning: Failed to activate plugin. Cloudron SSO requires 1 plugin to be installed and activated: OpenID Connect Generic. .
Sep 26 08:32:13 Error: No plugins activated.
</code></pre>
]]></description><link>https://forum.cloudron.io/topic/16017/wordpress-upgrading-but-not-starting-due-to-missing-redis-info</link><generator>RSS for Node</generator><lastBuildDate>Thu, 01 Oct 2026 08:42:45 GMT</lastBuildDate><atom:link href="https://forum.cloudron.io/topic/16017.rss" rel="self" type="application/rss+xml"/><pubDate>Sat, 26 Sep 2026 12:39:12 GMT</pubDate><ttl>60</ttl><item><title><![CDATA[Reply to Wordpress upgrading, but not starting, due to missing Redis info on Sat, 26 Sep 2026 15:29:02 GMT]]></title><description><![CDATA[<p dir="auto">All my WP sites are working fine on the latest package, but they're all non-SSO (users are app managed). I checked the redis info on one of my sites and there are values set in the credentials.txt. Just to confirm, this is the wp redis plugin: <a href="https://wordpress.org/plugins/redis-cache/" target="_blank" rel="noopener noreferrer nofollow ugc">https://wordpress.org/plugins/redis-cache/</a></p>
<p dir="auto">I'd retoggle the redis autoconfiguration in <code>CR dash &gt; wordpress app settings &gt; services</code></p>
<p dir="auto">If you want to use redis, enable the redis mentioned above, install the plugin I linked, and restart the app.</p>
<p dir="auto">If you want it off, delete the plugin altogether via the file manager, and make sure any other wp plugins (e.g. w3 total cache, wp-rocket, etc) don't have the redis option enabled either. Then, toggle off the redis autoconfiguration in the app's services tab and restart the app.</p>
<p dir="auto">edit: this is the openid plugin required for CR SSO to work: <a href="https://wordpress.org/plugins/daggerhart-openid-connect-generic/" target="_blank" rel="noopener noreferrer nofollow ugc">https://wordpress.org/plugins/daggerhart-openid-connect-generic/</a></p>
]]></description><link>https://forum.cloudron.io/post/130059</link><guid isPermaLink="true">https://forum.cloudron.io/post/130059</guid><dc:creator><![CDATA[humpty]]></dc:creator><pubDate>Sat, 26 Sep 2026 15:29:02 GMT</pubDate></item></channel></rss>