[SOLVED] Error launching Rocket.Chat?



  • Admittedly, I am trying to run Rocket.Chat from the git source you guys provide, however it crashes on startup:

    May 09 15:46:48 MongoDB shell version v3.6.3
    May 09 15:46:48 connecting to: mongodb://mongodb:27017/682da1dd-8ac6-43ff-815e-b36fb9940d8a
    May 09 15:46:48 MongoDB server version: 3.6.3
    May 09 15:46:48 WriteResult({
    May 09 15:46:48 "nMatched" : 0,
    May 09 15:46:48 "nUpserted" : 1,
    May 09 15:46:48 "nModified" : 0,
    May 09 15:46:48 "_id" : "SMTP_Password"
    May 09 15:46:48 })
    May 09 15:46:48 MongoDB shell version v3.6.3
    May 09 15:46:48 connecting to: mongodb://mongodb:27017/682da1dd-8ac6-43ff-815e-b36fb9940d8a
    May 09 15:46:48 MongoDB server version: 3.6.3
    May 09 15:46:48 WriteResult({ "nMatched" : 0, "nUpserted" : 1, "nModified" : 0, "_id" : "From_Email" })
    May 09 15:46:48 => Starting Rocket.Chat
    May 09 15:47:32 LocalStore: store created at
    May 09 15:47:32 LocalStore: store created at
    May 09 15:47:32 LocalStore: store created at
    May 09 15:47:32 Setting default file store to GridFS
    May 09 15:47:41 Warning: connect.session() MemoryStore is not
    May 09 15:47:41 designed for a production environment, as it will leak
    May 09 15:47:41 memory, and will not scale past a single process.
    May 09 15:48:12 Loaded the Apps Framework and loaded a total of 0 Apps!
    May 09 15:48:13 Updating process.env.MAIL_URL
    May 09 15:48:15 Using GridFS for custom sounds storage
    May 09 15:48:15 Using GridFS for custom emoji storage
    May 09 15:48:35 Error getting MongoDB version
    May 09 15:48:35 ➔ server.js:199 System ➔ error
    May 09 15:48:35 ➔ +---------------------------------------------------------------------------+
    May 09 15:48:35 ➔ | SERVER ERROR |
    May 09 15:48:35 ➔ +---------------------------------------------------------------------------+
    May 09 15:48:35 ➔ | |
    May 09 15:48:35 ➔ | Rocket.Chat Version: 1.0.1 |
    May 09 15:48:35 ➔ | NodeJS Version: 8.12.0 - x64 |
    May 09 15:48:35 ➔ | MongoDB Version: Error getting version |
    May 09 15:48:35 ➔ | MongoDB Engine: undefined |
    May 09 15:48:35 ➔ | Platform: linux |
    May 09 15:48:35 ➔ | Process Port: 3000 |
    May 09 15:48:35 ➔ | Site URL: https://chat.example.com |
    May 09 15:48:35 ➔ | ReplicaSet OpLog: Disabled |
    May 09 15:48:35 ➔ | Commit Hash: 4a3e6315c7 |
    May 09 15:48:35 ➔ | Commit Branch: HEAD |
    May 09 15:48:35 ➔ | |
    May 09 15:48:35 ➔ | OPLOG / REPLICASET IS REQUIRED TO RUN ROCKET.CHAT, MORE INFORMATION AT: |
    May 09 15:48:35 ➔ | https://go.rocket.chat/i/oplog-required |
    May 09 15:48:35 ➔ | |
    May 09 15:48:35 ➔ +---------------------------------------------------------------------------+
    

    Any idea's where to look?

    Edit: This was resolved by using the latest tag in the repo but not the latest master branch code.



  • The current version of Rocket.Chat is not yet supported on Cloudron due to changes how they use mongodb. So the latest master code base in git is a work in progress. Checkout the latest tags there to get a stable package version.


Log in to reply