Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.

SOLVED SMTP error with, but I don't use this?

  • Staff

    @scooke You can check if telnet 25 works on your server. If it doesn't i means that outbound mail is blocked from your server. You have to contact your VPS provider to unblock outbound port 25.

    If you are aware of this and don't care about sending out emails, then you can go to Email -> Select domain -> Outbound -> Disabled. That will remove the above notification.

  • @girish But, I want Outbound enabled. And under this option, it says I'm using the Built-in SMTP Server. So, does Cloudron use yahoo? When I click the Send Test Email icon an test email is successfully sent and received. And in the Raw Headers of the received email there is nothing about yahoo (just my Cloudron domain). So, did you mean in an earlier statement that Cloudron tests outgoing smtp servers? As in, a bunch of them? Why would it check the yahoo smtp server? (EDIT: I just checked and it looks like the yahoo smtp check was removed. This makes sense since the Yahoo smtp server isn't a default option in the Outbound settings, although it looks like someone could use it if they set it up manually.) And since that edit was 3 hours ago I haven't yet received another notice about this, so I guess it has been taken care of. Thank you!

  • Staff

    @scooke To check if outbound port 25 works, we connect through a list of hardcoded servers (the code link you pasted). One of them is yahoo. I have removed it for now.

  • @girish I keep having this error too, I think these checks are way too often, maybe we even get rate limited and that's why we get timeout errors ?
    it's the only smtp check that fails, across all the domains we host at armada 😕

  • App Dev

    @rmdes I don't think the rate limit is less than once every 30 minutes ^^

    However, the check could indeed be done at intervals depending on the situation. Like do the check immediately when the config is changed, do it every 30 minutes or so until it succeeds once, then only once every day, and try 3 times before printing a warning (it could just be a random network timeout)

  • It's increasing for me too. It used to be notifications for just one domain, but now two more are getting the same error notification. But, I thought you had removed this?

  • Staff

    Apparently yahoo started to block those requests from certain IPs/Cloudrons.
    It is removed in the code, but this requires a new release to be made first for your Cloudron to receive that change.

  • Staff

    TBH, I don't remember why we check every 30 mins for this. I will fix it to check just once a day for now. I agree with @mehdi though this can be made a lot smarter, but that's a task for another day.

  • I just started getting this error too:


  • Staff

    @jdaviescoates Yeah, removed it from our code for the next release. 5.5 should be out next week.