Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.



  • Spent a few hours trying to make the podcast feature work but no matter what I try, episodes do not get downloaded, sync in the ampache context, I have tried loads of different sources, take this one for example : https://ladycreme.libsyn.com/rss

    1e1ca37d-2628-41e9-b2cf-f9e77faeb2f2-image.png

    I can see the podcast folder being created in my library
    9dfc8073-6697-46c1-b2ac-f91e6f43bc24-image.png

    When I manually sync the entire podcast I can see this in the log :
    Nov 08 17:06:12 172.18.0.1 - - [08/Nov/2020:16:06:11 +0000] "POST /server/ajax.server.php?page=podcast&action=sync&podcast_id=5 HTTP/1.1" 200 541 "https://play.buzzworkers.com/" "Mozilla/5.0 (X11; Linux x86_64; rv:82.0) Gecko/20100101 Firefox/82.0" this is the log of the container

    the log of Ampache itself is going to /app/data/log/ampache/daily-log-file.txt

    this is what happens when a Sync is manually triggered
    https://paste.armada.digital/evepiwawuf.rb

    I have tried to get more debug information but I can't get more than that I hope it can help debug this but it seems there are bugs upstream, I'm not sure how to identify that part but willing to post this at Ampache if it helps moving forward.


  • New installation, default settings, Ampache can subscribe to a podcast but no matter what I try episodes do not get downloaded, the directory with the name of the podcast do get created in the /app/data/library/podcasts directory I created, so it seems to be able to write but I don't see any error message to help debug why podcasts episodes don't get donwloaded...

    Anyone having the same experience ?


  • been reading a lot of ampache issues and I think I understand the issue here, when you add a podcast RSS feed to ampache, it correctly register the podcast, scan existing episodes and then only future episodes gets downloaded ?

    going to confirm this but here is the log of subscribing to a podcast
    https://paste.armada.digital/ejicasoweh.rb


  • Confirmed, this "issue" can be put to solved, Podcast works !

    53c2fdf8-f828-4aa8-bd00-0051dda4fb1c-image.png

    Full log to see Ampache detecting new episodes, scanning which ones are already downloaded, downloding new ones and playing. https://paste.armada.digital/cowovotahe.makefile