Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


SOLVED Missing options in the Collabora Package

  • Staff

    So the new app package is out, however for the new toolbar to be enabled, you would have to reinstall the app! Luckily it is anyways stateless, so if you re-install it in the very same location, it should just work, since nextcloud only relies on the app origin.


  • @nebulon Thanks a lot for looking into this (and for already releasing a new package!). That works well for the new tool bar.
    Regarding the other issue, I was talking about adding / removing cells, not rows or columns (for which indeed there is the menu or cell / column headers). There is still not the option to add or remove cells (I did a fresh install of the app). It should normally be accessible on right click or in the sheet menu section (same setion as for adding entire rows or columns).

  • Staff

    Oh I see, I didn't even know one can remove a cell as such. Have to check again.


  • @nebulon Thanks! Removing a single cell is quite rare, but a range/array of cells is quite common. You can see the function on desktop version of LO, excel or on Google Sheets

  • Staff

    Indeed I can't find any button in the toolbar, but also no setting for this. You can, also for multicell, right-click and "Clear contents..." or after selecting the cells simply press "delete" on the keyboard.


  • @nebulon Yes you can do that to clear content but that doesn't do the same job as when you remove / add cells (my previous message meant to say Removing / Adding btw), it shifts (up/down right/left) the rest of the cells in a sheet, so it really is a different function than clearing the content (plus that trick would have only kind worked if the intention is to remove cells, not to add some).

    Its very weird as this is a very basic spreadsheet function and is documented in Collabora, and I am 99% positive it was there in previous Cloudron package.

    Btw, I did another search for this missing feature in reported issues upstream and could not find anything.


  • @nebulon Actually hold on a bit with this. I have noticed in a screenshot that the options seem to have disappear so I'll report upstream first.


  • Missing options for add / remove cells and protect / unprotect sheets will now be fixed upstream. Both commits have now been submitted.

    For add/remove cells one can use the Ctrl+ / Ctrl- shortcut already

  • Staff

    Interesting notes. To be honest, I basically never use spreadsheets so I mostly don't really know the functionality of such apps in the first place 😉


  • @nebulon I wish my coding skills would be good enough so I could replace my sophisticated spreadsheets with some slick and efficient code, and too not worry, or even know, about such functionalities 😉