@alejandrolengua Which service are you using at Mirhosting? I'll be honest with you, that is one complicated looking Dashboard! I managed to figure out how to generate a plain old Ubuntu 18.04 environment, but on the free trial I can't have an IP4 address. So I will just continue and see how this goes. Well, I was trying to install Cloudron on both Mirhosting, and Ultime Hosting (france), but both do not provide IP4 addresses for the free trials. And I don't really want to add funds to these either, sorry. But I can say that it is definitively getting stuck at => Installing software-properties-common and tails tells me specifically: Configuration file '/etc/resolvconf/resolv.conf.d/base' ==> File on system created by you or by a script. ==> File also in package provided by package maintainer. What would you like to do about it ? Your options are: Y or I : install the package maintainer's version N or O : keep your currently-installed version D : show the differences between the versions Z : start a shell to examine the situation The default action is to keep your current version. *** base (Y/I/N/O/D/Z) [default=N] ? Y It just hangs here. EDIT: I spoke too soon, after about 20 minutes it resumed. It seemed to fail again starting Docker. storage_driver=$(docker info | grep "Storage Driver" | sed 's/.*: //') Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running? I suspect that, according to the Dashboard, the environment I picked was Docker, and then I chose Ubuntu 18, whatever this jelastic is it already installed Docker in this service. Anyway, I ran systemctl start docker and systemctl daemon-reload, in one Terminal window, then reran the cloudron install script, and this time it resumed downloading all the various docker images. So, progress maybe? EDIT: FINAL UPDATE There was another fail, during the openjdk install. I wonder, I had to choose 8 "cloudlets" in order to get 1GB of ram for Cloudron, so I wonder if this is affecting the install. It doesn't sound like it is a physical instance, like a KVM VPS, so I suspect it is having trouble connecting everything and making it work. Maybe you should consider a plain old KVM? Good luck. (The setup before openjdk was nginx, which completed, but there was a warning : cat: /home/yellowtent/box/VERSION: No such file or directory ==> installer: Updating from to 5.4.1 <== ==> installer: updating docker nginx version: nginx/1.18.0 ==> installer: installing nginx 1.18 WARNING: apt does not have a stable CLI interface. Use with caution in scripts.): The final errors: Setting up openjdk-11-jre-headless:amd64 (11.0.8+10-0ubuntu1~18.04.1) ... update-alternatives: using /usr/lib/jvm/java-11-openjdk-amd64/bin/rmid to provide /usr/bin/rmid (rmid) in auto mode update-alternatives: error: error creating symbolic link '/usr/share/man/man1/rmid.1.gz.dpkg-tmp': No such file or directory dpkg: error processing package openjdk-11-jre-headless:amd64 (--configure): installed openjdk-11-jre-headless:amd64 package post-installation script subprocess returned error exit status 2 dpkg: dependency problems prevent configuration of default-jre-headless: default-jre-headless depends on openjdk-11-jre-headless; however: Package openjdk-11-jre-headless:amd64 is not configured yet. dpkg: error processing package default-jre-headless (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of ca-certificates-java: ca-certificates-java depends on openjdk-11-jre-headless | java8-runtime-headless; however: Package openjdk-11-jre-headless:amd64 is not configured yet. Package java8-runtime-headless is not installed. Package default-jre-headless which provides java8-runtime-headless is not configured yet. Package openjdk-11-jre-headless:amd64 which provides java8-runtime-headless is not configured yet. dpkg: error processing package ca-certificates-java (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: openjdk-11-jre-headless:amd64 default-jre-headless ca-certificates-java W: --force-yes is deprecated, use one of the options starting with --allow instead. E: Sub-process /usr/bin/dpkg returned an error code (1)