Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.

SOLVED Partial backup restore?

  • I changed hosting and was looking to restore the Cloudron instance on the new provider, however in the restore process I encountered a strange issue. After the restore none of the user accounts or apps were preserved, despite the presence of the app_ tars in the directory and then I was asked to create a new Admin account. This is strange as I know it was able to successfully download and decrypt the backup as the custom icon had been recovered from the process.

    Is there something obvious which would be causing this issue and are there any work arounds to restoring box or app data after setup?

  • I've made some progress, using a new instance on the older provider restored fine which leads be to believe its an issue that caused the restore to fail partway if the Domain settings aren't the same as when the backup was taken.

  • I attempted to change the Domain settings on the old provider then backup and restore from the new file, but that doesn't appear to work and instead I end up with the same initial issue. This would seem to imply that backups are inherently tied to the provider that Cloudron was initialized with and not the domain settings, which doesn't seem optimal because unlike the domain settings the provider cannot be changed in the GUI settings.

    Is there a .conf file which could be edited to change what Cloudron perceives as the provider? Or is there a way to restore User data after Cloudron has been initialized?

  • Staff

    The cloudron provider, eg. the one passed to cloudron-setup should not have any influence on the restore as such, as it is not part of the back in the first place. Do you see any errors in the logs ( journalctl -u box) during the cloudron setup once you selected a backup to restore from?

  • Staff

    I will mark this thread as "solved", since it is quite old. If this issue is still there, please post a reply.