Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.

SOLVED Installation hangs at "waiting for cloudron to be ready"

  • Hey All,

    I've tried setting up a cloudron instance on a leaseweb VPS; On a fresh ubuntu 16.04 install I ran:

    ./cloudron-setup --provider generic

    Everything seems to go fine until the very end, where the output says "Waiting for cloudron to be ready (this takes some time)". I've tried re-running it mutliple times, and tried letting it run and come back hours later, to find it's still "waiting." Attached is cloudron-setup.log. Any ideas about what might be going on?

  • Hm, I seem to have failed to actually attach the log (I don't even see an "attach" button, so I'm not sure what I intended). I've uploaded it here:

    I am at a total loss; if anyone has any suggestions of things to investigate I would be very appreciative.

  • Staff

    From the logs, it seems that it finished installation just fine, can you check systemctl status box to see if the main Cloudron process is working correctly? If so can you open your server's IP in the browser to proceed with the setup?

  • Aha, I'd glossed over the bit in the instructions that said to put the IP in the address bar -- I'd punched in the actual domain name and gotten a 404; that combined with the fact that the installer process saying it was waiting for cloudron to start had me thinking something had gone wrong. It's working now. Derp. Thanks for your help.