Failing at install



  • Hello, trying again since a while to install Cloudron in a VM (KVM Ubuntu 16.04 LTS) on Proxmox
    The process get stuck right after receive the DNS data and try to generate the certificate.
    He got in a silent loop with a constant message " Waiting for domain and certificate setup " on the browser.
    After 2 and half hours of waiting .. one time out message appears .
    The Server looks goods, the Domain Service (Goddady) shows the key pointing to Cloudron
    but y never reach the point to introduce mail and data to generate the certificate.
    Do you have any possible idea to look and solve this?
    Thanks in advance.

    Edited: Sorry I forgot to mention
    Install is self hosted using..
    ./cloudron-setup --provider generic
    Finish all the install process whit no issues..



  • If you used the right APIs for the GoDaddy domain, it should generate everything.



  • If the DNS records look fine after the setup attempt, you might fail at certificate setup. Can you verify that at least port 80 and 443 are open and reachable via dns?

    Also you should check the logs with sudo journalctl -u box, that should hopefully reveal a bit more details why it fails.



  • Thanks for your answer, and apologize about the delay...!!!
    Yes I'm pretty much following the procedure from Goddady on API Key and Secret generation..



  • Thanks for your time and sorry again for the delay to answer..

    About ports.. both are open and working... i just check from console and open them manually 80 and 443.

    AIso following the log from journalctl , DNS solve looks fine.. but complains about letsencrypt certificate
    Mention a error obtaining Acme certificate as could not get certificate, using fallback certs.
    is like.. (just the final since the log mention several attempts to challenge and failing to get the cert)

    name:"AcmeError"
    Reason:"external error"
    message: "Unexpected status: invalid"
    I will change to advanced install options and select another cert on a fresh install and check if a get the same ...
    Thanks for your help..



  • Solved!!
    But unfortunately... i cannot say what exactly I did to solve it.!!
    Because being frustrated i just download a old Ubuntu 16.04 server and didn't update anything..
    proceed with the install and worked.
    This ubuntu was the oldest one in the line..
    Thanks for your help and sorry for bother..!!
    Regards



  • how can I tag the post as Solved??



  • Oh indeed, currently Cloudron only supports Ubuntu 16.04 as being an LTS release for now. Sorry that it wasn't clear upfront.