Redoing the automatic DNS settings



  • Hey! Someone I work with accidentally deleted the "extra" DNS records on Digitalocean and now my [dot] domain [dot] com doesn't load. Both the www and the bare-domain point to the only app we use Cloudron for, which still works - however, the Cloudron dashboard itself is not accessible. Tried finding the records in the Docs to add manually but was unsuccessful. Any help would be appreciated!



  • Hi, in such a case you may restart the Cloudron service process with systemctl restart box via some ssh connection to the server. This should recreate the dashboard dns record.



  • @kctdfh were you able to recreate the DNS records?



  • Thanks for the reply! I managed to make it work with a wildcard record. My (only) app is on the www [dot] subdomain and the wildcard redirects everything to www [dot] so it works in our case. Strangely enough, my [dot] domain [dot] com also works now. No idea how or why.

    Should I still implement your suggested solution? Also, could I execute the command in the DigitalOcean browser console using my admin-level access (not root)?



  • The wildcard dns would cover that just fine, so no need to take further action at the moment. Eventually during an update the box service will be anyways restarted.

    Just for completeness, systemctl restart box requires root capabilities, so it has to run either as root user or through sudo