Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


Cloudron Admin Account Locked Out



  • Hello,

    I thought I had my password as I typed it when setting up this account but I must have typoed it.

    Going to the URL suggested by a google search results in the following errorr, note that I am positive I have the URL correct when doing so:

    https://my.example.com/api/v1/session/password/resetRequest.html

    Note also for this the previous and the next fact I will state that I have never made a token or used one for Cloudron Password resets.

    I also read that I could use a similar URL, with a token, after having selected info from the database. However I don't know how to do this because Cloudron installed MYSQL for me and I did not choose the root MYSQL password nor know what it is.

    So given both of those things that I tried, can someone suggest something to me please? Would really appreciate it. For the record this is for a non profit site that will be coming out soon dedicated to provide support to people recoering from various and all additions so it's for a good cause. Thanks.

    JW


  • Staff

    Hi,

    the URL you found is unfortunately some outdated URL from times when we used Oauth2.
    Please just visit https://my.example.com/login.html and you can reset your password there.

    If for some reason you do not receive an email to do so, you can login to your server via SSH as a last resort and run cloudron-support --admin-login, which will print temporary credentials to login to your Cloudron dashboard and fixup the password.



  • The command prints a blank username. For some reason, after the DNS setup I wasn't able to setup the admin account.
    A blank username means I can't login, as the form does not accept to leave it blank.

    Do I really have to reinstall?


  • Staff

    If you visit the raw IP of your Cloudron in the browser, it should first redirect you to the dns setup again, which if successful, will redirect you to the initial owner/admin setup, if this was not done yet. Otherwise your Cloudron might be in some odd state and a fresh install would be best to avoid any side-effects later on.



  • Yeah, had to do a fresh install. It all worked out in the end.


Log in to reply