Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


How to rebuild the container from the Web Terminal?



  • I've been installing plugins on discourse according to the instructions here. I'm having a problem where I'm not able to see the settings for installed plugins.

    For example, I installed discourse-subscriptions and added my stripe information but I can't get to the settings to set up the products and subscriptions.

    The discourse instructions say to rebuild the container after installing plugins. How do I do that within cloudron?


  • Staff

    @dev_nikema Have you tried restarting the app already? Under Console -> Restart App. This is required for new plugins to load after installation.



  • @girish Yes, I've restarted many times.


  • Staff

    @dev_nikema I was able to reproduce it. I think the issue is that a recent package introduced asset caching. The assets have to be cleared manually before the restart. In the terminal, run:

    rm -rf /run/discourse/public/assets/*
    

    Then restart the app. You should see the Subscriptions view after that (maybe refresh the browser if required).

    c3a4f964-b305-4b4f-825c-31ffae436058-image.png


  • Staff



  • Hello,

    I am facing the same issue, my plugins are not listed anymore in the admin "plugins" section, which prevent me to configure them properly. Running the command to remove the assets did not do anything (I tried it, repeatedly, restarting the app, installing new plugins, etc.). Everything is up to date as of today (discourse 2.5.0, cloudron 5.3.3). I am not sure when the page broke, it was working a couple months ago when I tuned the configuration of "discourse-chat-interaction" (this plugin, and the others, still work, their settings still appearing in other admin pages). I did nothing unusual since then on either the discourse or cloudron install.

    Is there a new step to perform since one of the latest discourse update?


  • Staff

    @jfrey So, a way to reproduce this is to install discourse, then install discourse-chat-interaction and then the plugin does not appear anymore in the admin "plugins" section?



  • I finally tested on a fresh install... and it works. So I dug some more, comparing the two installations, and realized at some point is a JS error on my regular install, linked to the chat integration plugin. In the end the code was outdated (it relied on a deprecated API), so I pulled the last version from git and... it worked.

    Long story short: this was a plugin bug 🤷 Sorry for the noise, and thanks for suggesting testing a separate install!


Log in to reply