Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.

Video conference call only available in local network....

  • Hi there,

    I have the weirdest thing going on. When i place a call from user to user, it only works if the two users are on the same network (locally).

    If i try to make a call through outside my network, for example my wife's mobile phone connected to her mobile internet provider and mine mobile phone setup the same way, it try's to connect, but there's no screen and/or sound?

    My setup of Cloudron is hosted at home. It lives in a Ubuntu 18.04 OS VM.

    I must say that i use Cloudflare and DigitalOcean for DNS on multiple domains.

    The only open port on my firewall from Cloudron to the outside world, is port:443 by the way. Do i have to open port:5349 TCP/UDP for stun/turn maybe??

  • App Dev

    Hi @DanTheMan,

    when the participants are unable to make a direct connection (since they are in different networks) then a Turn server is required for users to connect.

    Since you are hosting your Cloudron at home it feels like you are missing the appropriate port forwardings for the turn server itself and the upd ports it could take up (did not yet check which ports are configured here on the Cloudron side).

  • @fbartels
    I checked it with two ports open (for TURN/STUN) on my firewall.
    port:5349 tcp/udp
    port:3478 tcp/udp

    i also double checked if UFW was turned off by default in my VM, and it is...

    Still no result... 😞

  • App Dev

    @DanTheMan those ports are only part of what you need. You also need to to have the "relay ports", which usually are in the 49152-65535 range (both tcp and udp).

  • @fbartels I found the problem...

    I had the my.domain of my Cloudron homepage, DNS-proxied @Cloudflare.

    That way TURN/STUN is also proxied and in somekind of way blocked by Cloudflare. I think the problem is it exceeds the Cloudflare max upload policy, when things get over 150MB and are proxied.

    As soon as i greyed out the DNS-proxied @Cloudflare, things worked as a charm 🙂

    One question left.....

    I opened these ports on my firewall for TURN/STUN server to work,
    port:5349 tcp/udp
    port:3478 tcp/udp

    Is this the safe and described way to do this?

    The ports are redirected to the ip of my Cloudron instance running at home....