Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.



  • @d19dotca One last idea, check wp-config.php, is it pointing to the database name you edited?


  • @Lonk Good idea! Just checked though and yes indeed it's pointing to the right database, confirmed by comparing the value in wp-config with the value of show databases; in MySQL terminal.


  • @d19dotca Next idea then, weird caching issue. Can you try it in an incognito window?


  • @Lonk Ah I did that before, but just tried again in case and still no-dice, it still loads fine with old credentials. I've never run into this issue before. I've seen it the opposite where two passwords would work (i.e. the one from managed and then the one with LDAP on Managed when I went from Unmanaged to Managed once), but that was solved by simply removing the password from the database. This time it's almost the opposite where it'll take the old credentials, not the new ones (if AuthLDAP is disabled anyways which is expected), even though the old credentials don't appear to be stored anywhere.


  • @d19dotca Alright, throwing spaghetti at the wall now. 😂 Clone the installation and try to login in THAT installation.


  • @Lonk haha, fair enough, I'll try that too.


  • @Lonk Same thing on the cloned app 😞 I'm completely out of ideas. I can't explain this, haha.


  • @Lonk Btw I don’t think I said it but... thank you! I appreciate the time you’ve spent trying to troubleshoot it. 🙂


  • @Lonk Okay I think I may have fixed it, but I'm not certain I trust it. So what I did was generate a new password in the database directly with MD5, then saved that. Then tried and couldn't login again via a private window (so I could still remain logged in elsewhere), then I removed the password again from the database, wondering if that'd let me login with the old password still again, and now it seems to be working as expected when there's no password in there that it will forbid that user from logging in locally. So it seems good now... but not sure how much I trust this, lol. Will keep testing, but I think this may be finally working the way I expect it to, via LDAP Auth only.


  • @d19dotca Wordpress is my favorite and Cloudron is my new development passion so I’m happy to troubleshoot WP stuff to find edge cases that Cloudron may need to account for.

    I am very for making WP the best it can be on Cloudron. ☺

    I’m happy I’ve been able to help troubleshoot with you!