Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


SOLVED Minio credentials script error


  • When trying to run the script for changing credentials I get the following error:

    minio-credentials: line 3: use strict: command not found

    minio-credentials: line 5: syntax error near unexpected token `('

    minio-credentials: line 5: `const fs = require('fs');'

    This happens for both minio-credentials set and minio-credentials get

    Also the script is not recognised as a command I have to type: bash minio-credentials for it to run (and then it fails).

  • Staff

    @avatar1024 It's not a bash script, it's a nodejs script! You should be able to run it as-is, like:

    64625aea-19b7-48fe-a977-9f4920c13e78-image.png


  • @girish weird, "./" was the first thing I tried when it didn't on its own but there again it threw me an error about command not found and minio-credentials not being a folder. I resorted to trying bash in case I got it wrong and that's the only time it at least tried to run something (but ran into those errors).
    But have just done it again and it worked fine, I must have done something wrong the first time.
    Sorry for reporting a non issue and thanks for getting back