@girish yeah, you have to put sftp:// when using the quickconnect because the default for that is just ftp (although I wonder if that can be changed in the settings... I've not looked...)

When just adding a new site in the Site Manager there is just a dropdown and you don't have to type sftp://