Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


Skip to content
  • 1 Votes
    10 Posts
    229 Views
    O

    I wanted to let you know how I got everything to work, it might help other users.

    The initial issue was about DNS resolution. The quick fix is indeed to use the forward-everything option in unboud but with the previously used dns server. To find that value you just need to do a resolvectl and look at the value of the Current dns servers. In my case it was 10.0.2.3 (the one that was linked to my vpn on the host machine of the server). That is enough to fix the installation script losing internet.

    For the Configuration error: Domain resolves to ["XXX.XXX.XXX.XXX"] instead of IPv4 XX.XX.XX.XX the quick fix in my case (home server not directly exposed to the internet) was to install an openvpn server on the vps server (https://www.cyberciti.biz/faq/ubuntu-22-04-lts-set-up-openvpn-server-in-5-minutes/) and an openvpn client on my home server so that my home server gets the vps's IP address. In this setup you I also need a reverse proxy to expose the 80 and 443 ports from the home server to the vps.

  • 0 Votes
    5 Posts
    482 Views
    girishG

    @np_cloudron The Cloudron admin credentials and SSH credentials are different. The CLI credentials would have been set when you installed Ubuntu. Not sure where you got the ISO from, but maybe it has some default login?

    The enable SSH feature is for Cloudron support team to access your server. You should be able to access your server regardless of that.