Failing to build Cloudron Package



  • Hi Everyone,

    So, I'm having my hand in creating a package for Shiori in Cloudron.

    I have already successfully created a Docker image that installs and serves the application without any outside configuration necessary, but I run into an issue when I attempt to do the cloudron build step after creating my Manifest:

    > cloudron build
    Building io.cloudron.shiori@1.0.0
    
    ERROR Failed to build app: {
      "status": "Forbidden",
      "message": "dev group permissions required"
    } [ /usr/local/lib/node_modules/cloudron/src/helper.js:65:29 ]
    

    Are there any credentials that I need, or are there any application permissions that I overlooked in the packaging documentation?

    Thanks in advance. I'm really loving the project and service so far. It's going to be even better once I'm able to run custom packages.

    Enrique



  • @blueminder The buildbot (which cloudron build uses) is currently only enabled for people who have setup billing. If you don't want to do that at the moment, you can simply build the docker image locally and then do cloudron install --image.



  • For others reading this, currently the process of giving build service access is not automated. If you need access, please send us an email to support@cloudron.io.