Cloudron MySQL Rate Limit



  • Hello,
    During importing a very FAT .ical file in NextCloud, I get some SQL error and I would like to check if they came from the rate limit in the IPtable, how can I by-pass or regulate that ?

    Thanks,
    Saglagla



  • Here a log part :
    Apr 09 16:47:46 [Mon Apr 09 16:47:46.427841 2018] [:error] [pid 748] [client 172.18.0.1:48502] PHP Fatal error: Uncaught Doctrine\DBAL\DBALException: Failed to connect to the database: An exception occured in driver: SQLSTATE[08006] [7] FATAL: remaining connection slots are reserved for non-replication superuser connections in /app/code/lib/private/DB/Connection.php:64\nStack trace:\n#0 /app/code/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\DB\Connection->connect()\n#1 /app/code/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\DBAL\Connection->getDatabasePlatformVersion()\n#2 /app/code/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\DBAL\Connection->detectDatabasePlatform()\n#3 /app/code/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(623): Doctrine\DBAL\Connection->getDatabasePlatform()\n#4 /app/code/lib/private/DB/Connection.php(151): Doctrine\DBAL\Connection->setTransactionIsolation(2)\n#5 /app/code/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php(172): OC\DB\Connection->__construct(Array, Object(Doctrine\DBAL\Driver\PDOPgSql\Driver), Objec in /app/code/lib/private/DB/Connection.php on line 64


  • Cloudron.io team

    I guess this is coming from PostgreSQL since that is what the next cloud app uses. There is no rate limit in IPTables but there is a max_connection setting of 100. Strange that nextcloud is hitting such a high limit but I am guessing it is some bug in the importer.

    There is a suggestion athttps://productforums.google.com/forum/?hl=en#!category-topic/calendar/calendar-not-loading/EqOUPboHrmU on how to break up iCal file into smaller parts and import them one by one. @saglagla maybe you can try that?



  • @girish I have a 238 ko iCal file.
    I've split it in twice and I went from 250 importation err from 1 err.
    The problem should come from that, thanks!

    I was at the beginning thinking about it (splitting the file) but after that, I was focusing on RateLimit - wrong way! Also, I advise people which want to import a big file to increase drastically the mem allowance of the app (2Gb in my case)


 

Looks like your connection to Cloudron Forum was lost, please wait while we try to reconnect.