Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.

SOLVED User management changed when app moved from one cloudron to another

  • While cleaning up a number of old cloudrons merging them into one new cloudron (2.1.1) where I try to host several domains, I tried to move the taiga app from old to new cloudron using Cloudron CLI tool. The old Taiga was set to handle its own user management, but when it is moved to the new cloudron it automatically get changed to "Allow all users from this cloudron"

    This also happens to other apps (Rocket.Chat, Etherpad, and naked domain Wordpress so far) when moved from one cloudron to another, and is a serious problem. App users that has no user account in Cloudron will not get access to that app any longer, including myself.

  • Staff

    @stoccafisso When you install apps using the CLI tool, it uses Cloudron SSO by default. Use cloudron install --no-sso --backup <id> and that will solve your problem.

  • @girish Tank you. I apologise for my ignorance. I will try the --no-sso part 🙂