App Source Size Limit



  • Hi Guys ,
    I am trying to pack sugarizer(https://github.com/llaske/sugarizer) and sugarizer server(https://github.com/llaske/sugarizer-server) . I have added a Dockerfile in sugarizer dir in which I am adding both sugarizer and sugarizer-server dir to /app/code/sugarizer and app/code/sugarizer-server. Everytime I start with the build command , it crashed with error .

    "ERROR Failed to build app. The app source is too large.
    Please adjust your .dockerignore file to only include neccessary files."

    Is there anyway to alter this limit? I tried shrinking sugarizer by 150MB around , leaving it still a 150MB package but still the error persists.



  • Often this is the case when not needed resources from the repo are pushed to the build server. You can filter those out by using a .dockerignore file in the repo. See for example https://git.cloudron.io/cloudron/wekan-app/blob/master/.dockerignore



  • Please explain "Not needed resources". I cant find anything that seems extra or could be avoided. I already have a dockerignore file with entries for node_modules and git folders.



  • Oh ok, then the app is really this large. I guess we have to increase the limit then on the buildserver. I will do so in some time and keep this thread updated accordingly.



  • Before I adjust the source site limit, just to clarify, generally the package code itself should not be that large as it mostly contains a few scripts and metadata. The actual app code is usually fetched in the Dockerfile. Do you have a Cloudron package repo somewhere online to take a look, or did you intend to put the Cloudron package files directly into the app repo?



  • I have read the cloudron packaging documentation and according to that, I added a Docker file in my sugarizer dir with ADD commands to add the whole content of /sugarizer/ dir as well as /sugarizer-server/ dir to /app/code/sugarizer/ and /app/code/sugarizer-server/ .



  • Are you adding the contents of .git, node_modules etc by any chance as part of your ADD command?

    I suspect you are developing the cloudron package inside your app's git repo itself. If you do this, you have to be careful not to add build and version control artifacts as part of Cloudron image creation. Maybe you can hop onto chat.cloudron.io and we can help you there.



  • @girish Hi , I have made sure that that my repo should not have any git data or meta data. I even tried shrinking the app on my end as much as I can. If you want to take a look on the app , here it is : https://github.com/llaske/sugarizer