Collabora Issue Setting Domain



  • Hello,

    I have been having issues getting the Collabora app connected to Nextcloud. I believe the issue is saving the Nextcloud domain in Collabora. When I use the default regex and click "Save", it hangs. The browser console show a constant stream of 502 errors to the URLhttps://docs.mydomain.com/hosting/discovery, which is the Collabora domain. I've tried reinstalling Collabora multiple times, restarting it, etc., and nothing seems to help.

    Thanks!



  • Do you happen to have any special characters in your domain? The regexp handling in collabora had some issues in the past. By default the collabora app would be setup to allow all apps (nextcloud instances) on the same cloudron domain.



  • No special characters at all. I've tried reinstalling Collabora and not manually setting the domain, but that gives a error in Nextcloud, "Internal Server Error".



  • That is indeed strange and I am not able to reproduce this. Can you disable all NextCloud addons, besides the Collabora one and try again? Maybe something is interfering there.



  • One idea is to see if you can reproduce it athttps://my-demo.cloudron.me/#/apps (username: cloudron password: cloudron) and take it from there.

    I also pushed a doc yesterday for collabora, if it helps -https://cloudron.io/documentation/apps/collabora/



  • I've tried disabling all the other addons in Nextcloud, but no dice. I looked in the logs and there's nothing out of the ordinary.

    Girish, I tried to replicate it on your setup, but I can't find anywhere to enable Collabora. I have the option where the documentation you posted says it should be on my Nextcloud instance, but on yours it's not there.