Restore from Minio is not easy



  • Hi guys

    General information
    I'm trying to migrate from 16.04 to 18.04 and set up the new server parallel to the old one.

    Details
    Here are my experiences so far:

    At the first attempts, when using the restore functionality at the setup process I get two results:
    When I try to restore from my rsync backup, after some time I just get redirected to the setup startpage and nothing happens This behaviour I could reproduce twice already, but this time I was also prepared with a .tar backup:

    When I tried to restore from my tarball backup, I got the following error:

    EPERM: operation not permitted, utime '/home/yellowtent/boxdata/mail/haraka-config'
    

    I thought maybe it was that the time in the just finished backup was ahead of the server time, so i checked and the server was still on UTC instead of CET. After changing it to the correct timezone and verification with date I did have the correct time. However, the error persisted.

    I tried then again with rsync, which gave me following output:

    unable to create path: EACCES: permission denied, mkdir '/home/yellowtent/boxdata/mail/vmail/<user>@<domain>.<tld>'
    

    So I went into the vmail directory, which had the permissions set to builder:builder. I changed it to yellowtent:yellowtent and tried again. And then actually things started to happen, as I saw it in the box.log.

    The whole process took some time, while not seeing any progress over web - also after it finished it was still at the restoring screen. So I just knew because of my tail -f on the log that everything seems to be up and running and manually changed from restore page to main page.

    Verification

    After logging in, everything looked good, all apps were installed. I checked some apps, Sogo, Nextcloud etc seem to have all the data. However, e-mail didn't. All mails were gone on that account I checked. And it doesn't seem to be possible to get them back by restoring the rainloop app (as mails are probably not stored in the webmail apps).

    This lead me to the decision, to rollback to the old installation and find out via the forum how to continue. This way I won't have a split situation for emails and mixed backups.

    Problem statement
    How can I restore all my data without any loss?

    Further debugging
    I can offer the possibility to trash the new VM and setup a new one, so if nebulon or girish want to have a closer look at the restore topic this would absolutely be possible.

    Before shutting the Ubuntu 18.04 VM I backed up all Cloudron logs as well as the logs in /var/log/*. So these are at hand.

    Additional questions

    1. One thing that confused me additionally: The size of the tar backup is 16G compared to 150G in rsync. To me rsync looks like a full disk backup while tar just backups userdata and the cloudron specific data. Is this correct or is my tar backup broken?

    2. Are the TLS keys and certificates restored from the backup as well or are all certificates new? Didn't have time to check, but it could break DNSSEC TLSA if the keys are new.

    Thx in advance for your support!



  • @gml The ownership error, I have seen this error before. I thought we already fixed this. Can you confirm that you are on the latest release 3.5.2?

    To answer your other questions:

    • The rsync and tar backup are exactly the same content wise. One is flat on disk and another is the whole thing zipped together. Can you tell me how you determined those backup sizes?
    1. That's correct. The TLS keys and certificates are restored from the backup. New certificates are not obtained.


  • Hi @girish

    Thx for your answer!

    Yes, it's 3.5.2 on the 16.04 and 18.04 VM

    I see the size as I made a bucket for tar and a bucket for rsync and i can see the size of each at the page of my provider. This behavior is something I could reproduce. Even tough there is some compression a compression rate of 1:10 made me wonder..

    What do you think about the mails that weren't synced? Could it be in relationship to one of the errors?



  • @gml The first EPERM error is indeed a bug and we will push a fix in the coming days with the fix. I will keep this post updated.



  • The PERM issue is fixed now, we will get the release out early next week.

    The backup size issue needs debugging. Are you able to join our chat, so we can try to figure what is happening there? Please ping girish or nebulon there.



  • This is fixed in 3.5.4


Log in to reply