Syncthing - URL redirected to localhost?!



  • I have a weird situation:

    • Installed and configured syncthing on my Cloudron server (at home) while at work at https://sync.mydomain.tld
    • installed and configured Syncthing on my work PC
    • work PC synced fine to Syncthing on Cloudron
    • at Home, tried to configure Syncthing on my Mac (in the same network as the Cloudron Server) with the MacOS app (https://github.com/syncthing/syncthing-macos/releases/latest). First, I accidentally entered the address and API key of Syncthing on Cloudron in the Mac App, then changed it to the local one (https://127.0.0.1:8384) but it would not accept the local API key. Opening the Web Interface worked fine though.
    • now, the I open https://sync.mydomain.tld, it actually tries to open localhost:3000?! I checked /etc/hosts/, there’s no such entry. It happens even on another mobile device with WiFi turned off?!

    I don’t get it. Googled, found nothing. I’m pretty sure it’s one of those situations when I’ll slap myself later for not getting it but right now I’m at a loss.



  • NVM, worked again after re-starting the Syncthing app in Cloudron. Still don't understand...



  • Strange, let us know here if the problem resurfaces.


Log in to reply