Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


SOLVED imap connections limted to 10 makes clients fail to connect


  • After I moved my mail-server to cloudron, I experienced regular erros on my thunderbird, saying the server rejected my login.
    It was not updating the IMAP-folders and the only way to read my emails, was through K-9.
    in a quiet moment, I installed KDEPIM and Kontact provided me with a more helpful err-msg.

    in German:

    Anmeldung fehlgeschlagen, die Serverantwort lautet:
    A000002 NO Maximum number of connections from user+IP exeeded (mail_max_userip_connections=10) [ UNAVAILABLE ]
    

    I do have 2 accounts configured in my mail-client, with a lot of IMAP-folders and never experienced a pbl. with other mail-servers I used so far.

    ClientSystem: Debian buster,
    KDE 5.54
    thunderbird: 60.5.1-1
    kdepim: 4:17.12.3+5.102
    kontact: 4:18.08.3-1

    Screenshot_20190309_215637.png

  • Staff

    @chymian It seems it's hitting the rate limit. Can you try this:

    docker exec -ti mail /bin/bash
    

    edit /run/dovecot/dovecot.conf. add something like this:

    protocol imap {
      mail_max_userip_connections = 50
    }
    

    Then (inside the container)

    supervisorctl restart dovecot
    

    Note that the above setting will not persist server reboot. If the above works, we can get it fixed in the coming update.


  • from a quick test, it seems to work with a limit set to 50
    TB works, even with sieve editor open.
    if I don't report otherwise within a week, it is a working solution.

    thx johannes
    guenter

  • Staff

    OK, I have fixed the code as well, so it will part of next update (3.6). Until then please update file.