EEXIST file already exists



  • Hi,

    The last two security updates went fine except that my NextCloud instance gave an error both times. The first time I got this fixed by recovering the NextCloud instance to a previous version, however this time this does not seem to work and I cannot get my NextCloud instance to boot again.. The error shows:

    EEXIST: file already exists, mkdir '/home/yellowtent/appsdata/<app ID>'
    

    I believe the problem lies in the fact that I moved this instance to a different location using the guide for storage moving.

    Any ideas? A search over the internet says that the problem lies in the npm package, but I am hesitant on making significant changes to installed packages..

    Hoping to get my server running again soon, thank you for your time.



  • Hi there,

    this looks like the restore logic refuses to overwrite the existing app directory. If you like we can take a look directly on your server to check if this is something we have to fix in code. If so please enable ssh support for our team and send an email with your cloudron domain to support@cloudron.io

    Best,
    Johannes



  • Thank you @nebulon for solving this issue off-forums.

    For future reference: problem was caused by the external storage being unmounted after a reboot. Remounting the storage drive (I use a netcup VPS) and then repairing in the Cloudron dashboard solved the problem. Including the mounting in /etc/fstab solved this issue for following updates/reboots.


Log in to reply