Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


How to disable user signup?



  • I have set the Wekan app config for users of my cloudron only but the wekan page is accessible and offers a link to sign up. I was able to make a new user there that has full access to the wekan app, but does not show up in cloudron.

    How do I lock this down so that the Wekan app stays private (invite-only)?


  • Staff

    @darcyc The first user to login is made the Wekan administrator. There is a Admin Panel under the name and from there you can disable self-registration.

    3fbe4aa0-0022-42b8-beca-98938bcdfe7a-image.png

    But thanks for bringing this up, this is an important issue. I will fix up the package immediately to disable registration on install by default.



  • @girish Thank you for the reply. I did find some posts about a mysterious Admin Panel on the Wekan wiki, but I do not have that option on my user id in my installation so I thought maybe the info was out of date.

    I only have two users in my cloudron, and one of them (me) would have been the first user in Wekan. Is there any way to see what other users the Wekan app thinks it might have?

    Update: I just checked with my other user, and they don't have the Admin Panel either. So somehow I have ended up with an admin-less wekan 😞 Worst case I'll delete it and try again, but I'd prefer not to lose the data already entered if there is a simple alternative.



  • Looks like this option might be broken in the Admin Panel at the moment anyhow: https://github.com/wekan/wekan/issues/2839

    Meanwhile, that thread does suggest a workaround to "redirect the signup page to signin". That sounds good, but I haven't the faintest idea how to do that. Is that something that could be done in Cloudron settings somewhere?



  • @girish said in How to disable user signup?:

    But thanks for bringing this up, this is an important issue. I will fix up the package immediately to disable registration on install by default

    Just to add, this is (or at least was) the same with Rocket.Chat, ie when I installed it and chose Cloudron users people can still register independently on Rocket.Chat. This happens to be how I actually want it, but I guess others may not want that at all.



  • @darcyc Can try to change the configuration file manually?



  • @murgero I'd be happy to, but the mention that I found on github about disabling signin indicated that you would have to rebuild the app, and I don't think I'm up for that. I'll look again and see if I can find something else or maybe I read it wrong. If you have a hint about where to look, that'd be great 🙂

    Also, I think I have a separate problem, in that I don't have an admin user on the wekan, so I'm also looking for a way to make my user the admin.


  • Staff

    @darcyc I am pushing a fix shortly, hold on.


  • Staff

    I have pushed an update to Wekan now that disables user registration by default. You can, of course, explicitly turn it on.

    @darcyc To make yourself an admin, run this command - https://cloudron.io/documentation/apps/wekan/#admin



  • @girish Thank you!!!! I'm now an admin, and I see that somehow I ended up with a completely blank account that was the original admin. Plus I can see the test user I added via the signup, so even if turning off signups doesn't work just yet (because of the issue on the wekan side) at least I can keep an eye out for unexpected users.

    Thanks very much for the help and super-quick response 🙂


  • Staff

    @darcyc Turning off sign ups works for me here. I think the bug is that the "register" link is still shown in the login page despite disabling registration. Bbut if you click register and try to register, one cannot login without an invite code.



  • @girish said in How to disable user signup?:

    Bbut if you click register and try to register, one cannot login without an invite code.

    Ah, I see. I just tested this and you are correct. That is good enough!

    I do still have these two extra "blank" users (one admin and one not) that I cannot figure out how to get rid of and cannot edit (I tried to set them to Inactive, but the Save button doesn't appear to do anything), but I also cannot login as them, so I think it's okay. (These users are only in wekan, not in cloudron. My cloudron users are just the ones I expect to see.)

    Thanks for the help, and for the update to the docs. You are doing wonderful work trying to make self-hosting feasible for folks willing to try.


Log in to reply