Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.

SOLVED Changing calendars on an event via Calendar app on macOS and iOS doesn't work

  • Staff

    Actually you can open a custom crafted url with the app package version like:

    The version can be obtained from the git repo tags

  • @nebulon So interestingly enough in my testing, the issue didn't occur in the old version but also didn't occur in the new version when I upgraded it. So I'm not sure what the root cause is anymore, but presumably not an app issue I guess. May be more to do with my own data somehow, maybe some corruption. I think I'll create a new Radicale on my server and migrate the data and see if that fixes it.

  • @nebulon Upon further testing there actually was an issue when I tried a new Radicale server, I just didn't see it at first as it wasn't the exact same issue. I no longer receive 409 Conflict messages but 502 Bad Gateway messages whenever a MOVE command is made. I'm not sure why the error has changed, but perhaps it had to do with a sort of "reset" of the data by moving from one Radicale server to another.

    I found this in the Radicale GitHub Issues list which is very similar (if not the same):

    Here is the exact logs I see (minus the names of the collections):

    Aug 19 23:07:50 [2020-08-20 06:07:50 +0000] [1/Thread-540] [INFO] MOVE request for '/<username>/<sourceCalendar>/0D990B62-D6CF-4E10-805F-3AB51C21CF21.ics' received from '<IP>' (forwarded by using 'macOS/11.0 (20A5343i) CalendarAgent/950'
    Aug 19 23:07:50 [2020-08-20 06:07:50 +0000] [1/Thread-540] [INFO] Successful login: '<username>'
    Aug 19 23:07:50 [2020-08-20 06:07:50 +0000] [1/Thread-540] [INFO] Unsupported destination address: 'https://calendars.<domain.<tld>/<username>/<destinationCalendar>/0D990B62-D6CF-4E10-805F-3AB51C21CF21.ics'
    Aug 19 23:07:50 [2020-08-20 06:07:50 +0000] [1/Thread-540] [INFO] MOVE response status for '/d19dotca/<sourceCalendar>/0D990B62-D6CF-4E10-805F-3AB51C21CF21.ics' in 0.197 seconds: 502 Bad Gateway

    Looks like it could have to do with the reverse proxy in front of Radicale. Seems that this may be a mix of how Nginx is configured in front of Radicale and I guess changes in Radicale itself. So this seems to need an update to the Nginx rules, perhaps, with the latest Radicale version.

  • @nebulon - Any updates on this one by any chance? Seems to be related to both Radicale but also the proxy configuration which I assume is part of the app package details.

  • Staff

    @d19dotca Johannes is on vacation this week, just a heads up.

  • @girish Okay, thanks for that heads up. I'll wait a bit then before following-up again. 🙂

  • @nebulon - Just wanted to check in on this. Also a quick update: I tried updating the latest package pushed out today, but the same issue occurs on the 502 Bad Gateway.

  • @nebulon - Just wanted to check in again as I'm still running into this issue and it's been stale for nearly three weeks now. No rush but just figured I'd make sure this was still on your radar as it's becoming a bigger impact as time goes on. Thank you in advance.

  • @nebulon - Just wanted to check in again as this one has been sitting for about 25 days, and it's becoming a bigger issue with my productivity workflow, or more of an annoyance let's say than a real issue but something I'd love too see resolved sooner than later if possible.

  • Staff

    Ah right thanks for the reminder, it is still on my list...

  • Staff

    I was trying to reproduce this now, however I don't have a mac or iOS device and I wasn't able to get a calendar client otherwise to use the MOVE command. They all DELETE/ADD events when moving them from one to another calendar.

    Will see if I can get some mac on hand to test this. Just for confirmation, both calendars are within the same radicale instance? Which calendaring apps did you use on mac?

  • @nebulon Yes, same Radicale instance for all my calendars. And I just used the built-in Calendar app that comes with macOS. 🙂

  • @nebulon Quick update to say I tried on the latest Radicale update you deployed earlier today, but same thing. 502 Bad Gateway error upon MOVE commands.

  • Staff

    Ok got access to a macbook, however it works for me:

    18:47:20 - [2020-09-15 16:47:20 +0000] [1/Thread-2416] [INFO] GET response status for '/' in 0.000 seconds: 302 Found
    18:47:26 - [2020-09-15 16:47:26 +0000] [1/Thread-2417] [INFO] MOVE request for '/nebulon/7605fbf0-7bd3-63a0-c8df-e5c4af4f34fd/f9d03e14-303a-4f5d-8c8e-eeaf4cb33690.ics' received from '' (forwarded by using 'Mac+OS+X/10.14.6 (18G103) CalendarAgent/416.5.1'
    18:47:26 - [2020-09-15 16:47:26 +0000] [1/Thread-2417] [INFO] Successful login: 'nebulon'
    18:47:26 - [2020-09-15 16:47:26 +0000] [1/Thread-2417] [INFO] MOVE response status for '/nebulon/7605fbf0-7bd3-63a0-c8df-e5c4af4f34fd/f9d03e14-303a-4f5d-8c8e-eeaf4cb33690.ics' in 0.192 seconds: 201 Created
    18:47:26 - [2020-09-15 16:47:26 +0000] [1/Thread-2418] [INFO] PROPFIND request for '/nebulon/f1ce483f-5dac-87e1-d2c7-e4706444faab/f9d03e14-303a-4f5d-8c8e-eeaf4cb33690.ics' with depth '0' received from '' (forwarded by using 'Mac+OS+X/10.14.6 (18G103) CalendarAgent/416.5.1'
    18:47:26 - [2020-09-15 16:47:26 +0000] [1/Thread-2418] [INFO] Successful login: 'nebulon'
    18:47:26 - [2020-09-15 16:47:26 +0000] [1/Thread-2418] [INFO] PROPFIND response status for '/nebulon/f1ce483f-5dac-87e1-d2c7-e4706444faab/f9d03e14-303a-4f5d-8c8e-eeaf4cb33690.ics' with depth '0' in 0.180 seconds: 207 Multi-Status

    Are you using calendars of different users?

  • Staff

    Ok I also tried with different accounts and then the macos client also performs a DELETE+ADD instead of a MOVE, so not sure how to debug this further for me 😕

  • Staff

    The log message of "Unsupported destination address" comes from The code there says to_url.netloc != environ["HTTP_HOST"]. From a casual reading, could it be that the domain of the calendar is hardcoded somewhere inside radicale? Meaning, if the user moved the radicale app from one location to another, maybe some internal entries are not patched up?

    This happens for SOGo which I discovered just a couple of days back -

  • @nebulon & @girish - very interesting. According to the Radicale GitHub it's been an issue for others before and sometimes fixed and sometimes needing the proxy to be modified.

    One thing worth mentioning in case this is an issue, though it is released now (or will be very soon so this will be an issue down the road perhaps) is I was running macOS 11 (i.e. the latest one released for September 2020 called Big Sur, running on their public beta builds earlier). So maybe there's something different now in how their Calendar app handles changes to calendars - no longer doing a DELETE+ADD but a MOVE now - although it's odd because it wasn't an issue earlier in the beta builds and I think either way they're still doing it correctly (just maybe different) as a MOVE method is a valid command to Radicale. Though this may explain why it works for you and not me, as we're running different macOS versions.

    You may be on to something though about that part of the code in their GitHub project with "to_url.netloc != environ["HTTP_HOST"]". Never seen that before and it's never been an issue before to my knowledge. Any ideas where that might be stored though? Is that something I need to change in my environment or is that more of an app thing? I was able to reproduce it before on a brand new Radicale deployment, so I assume this isn't something I have control over?

  • Seems the HTTP_HOST value is set too in the proxy according to the docs:
    I assume it's using that set in the nginx reverse proxy in it's comparison logic for the MOVE command? Though still doesn't necessarily explain why it works for you guys though, as I assume that same value would be set anyways, it's the hostname of the app after all, isn't it?

  • Staff

    I don't think the macOS version is the issue here, since I also see the MOVE command being used (but in my case successfully) if I move events between calendars of the same user.

    In your case, did you ever move that radicale app instance from one domain/subdomain to another?

Log in to reply