Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.

SOLVED [bug] collabora: failed to get new child

  • Hi,
    on my cloudron I have
    Collabora Office
    Package v1.8.4-1
    App v4.2.6-2

    linked to Nextcloud
    Package v4.6.4
    App v19.0.3

    When I try to open a .odt file, it's stuck on this:


    And the document never loads.

    The logs says this:


    I have already tried to remove/install collabora. No effect.

    Any chance this is happening to somebody else ?
    How to solve the issue please ?

  • App Dev

    @valkalon This may be an issue for the Collabora team. Cloudron only built the app you install in the server, they did not make Collabora.

    Looking into this on Google, it seems that an nginx / apache config change may or may not be needed:

  • Staff

    Haven't see this before. @nebulon any ideas?

    @valkalon Just to double check, this happens all the time on a simple fresh installation of collabora?

  • Staff

    I haven't seen this before. Does this happen with any document in your case or just any odt or even only one specific odt?

  • @girish The bug appears at random with a simple fresh installation of collabora.
    @nebulon It happens with any .odt document of any size.

    I tried to get a consistent scenario to reproduce the bug, unfortunately I cannot find the conditions.

    In the last 2 weeks I had this bug often and at random (failed to get new child in the logs). Even after restarting the cloudron. This morning, trying to make a short video to show you, I cannot reproduce the bug...

    Thankx @murgero for the link, that feels like the problem could come from an interaction with the web server indeed.

    I also found this link:, which mentions the issue coming from a possible timeout. That could be the case since my cloudron is installed on an HDD server (not SSD).

    If I'm the only person facing this issue, I don't want to waste your time guys, feel free to put it on hold. I'll consider it comes from my setup and can update when I have more details to provide.

  • Staff

    FWIW, I tried to reproduce this by re-installing collabora 4-5 times, however I have been unable to. I guess this is upstream race/timing issue.

  • Staff

    A new version was released as a Cloudron package now, would be good to see if that issue is fixed now with Collabora 6.4.0

  • Thanks Nebulon, so far so good, no problem appeared with the update. Will keep you posted if happens again. Feel free to close the topic

Log in to reply