Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


  • Staff

    Apparently due to the Postgres addon collation changes, new matrix does not work anymore (existing installations will continue to work):

    Oct 12 14:31:15 2020-10-12 12:31:15,437 - twisted - 231 - ERROR - None - ****************************************************
    Oct 12 14:31:15 2020-10-12 12:31:15,438 - twisted - 231 - ERROR - None - Database is incorrectly configured:
    Oct 12 14:31:15 2020-10-12 12:31:15,439 - twisted - 231 - ERROR - None -
    Oct 12 14:31:15 2020-10-12 12:31:15,439 - twisted - 231 - ERROR - None - - 'COLLATE' is set to 'C.UTF-8'. Should be 'C'
    Oct 12 14:31:15 2020-10-12 12:31:15,439 - twisted - 231 - ERROR - None - - 'CTYPE' is set to 'C.UTF-8'. Should be 'C'
    Oct 12 14:31:15 2020-10-12 12:31:15,440 - twisted - 231 - ERROR - None -
    Oct 12 14:31:15 2020-10-12 12:31:15,440 - twisted - 231 - ERROR - None - See docs/postgres.md for more information.
    Oct 12 14:31:15 2020-10-12 12:31:15,441 - twisted - 231 - ERROR - None - ****************************************************
    

    If you are using Matrix actively, make sure to not update your Cloudron until this is fixed! (ignore this)

  • App Dev

    @nebulon I am on 5.6.2 and Matrix is working fine for me.

  • Staff

    Existing installations won't be affected. The addon changes only apply to new app installs.

  • App Dev

    @girish I deleted my comment as to not confuse those looking for a resolution - sorry about that.

  • Staff

    @murgero I thought your comment was good, in fact 🙂 Because @nebulon said, don't update Cloudron (but it doesn't affect existing installations). I will edit his post.