Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


SOLVED PeerTube LDAP not working


  • Hello All =]

    Attempting to install and mess with PeerTube.. I configured it to use Cloudron LDAP to authenticate with the Cloudron User Directory but it does not appear to work.
    Is this supposed to work out of the box or are there additional config to be made?

    Checked the Docs & Took a look @ /app/data/production.yaml but did not see anything stick out

    Tried using a username and the email but it just says Incorrect user or PW =/

    Any insight or suggestions are appreciated!

    Best,
    Nick

  • Staff

    @plusone-nick Is this an existing installation? LDAP is also integrated in the latest peertube package. So, maybe just re-install? I didn't pay particular attention to whether the package updates properly when it was listed as 'unstable'.


  • @girish I did test an unstable version but for this use case I had just installed a fresh before logging this post. I will try from scratch again and advise of the results =]


  • @girish after some testing:

    1 - I was able to get the expected results of cloudron LDAP users being able to log into a new peertube installation (on my clients org)

    2 - when testing on my org LDAP does not work on fresh installs. Tried it on a subdomain and a secondary domain (root) with no luck

    3 - What i did find:

    • Both orgs on v5.6.3
    • Both PeerTube installs on 2.4.0 (v1.1.1)

    4 - My clients org has the plugin installed automatically - where as my installs are missing the LDAP plugin for some reason 🤷♂

    Any advice?

  • Staff

    @plusone-nick Are the two intallations on different machines? Now that I look into the setup code, there is possibly a race that it may not install the plugin correctly on slow machines.

    Can you download the full logs of the install that is not working and send it to support@cloudron.io ?


  • @girish No they are not on the same machine/setup

    The one that is working as expected is hosted on DO

    Where as my org that is not working is hosted on site (Dell R610 - 12 cores & 64 GB RAM)

    • Technically the Dell has like 7X more resources than the DO instance but as It is self administered there is/could be some other differences....

    I will send the logs =]

  • Staff

    Thanks for sending over the logs, looking into it.

  • Staff

    The issue here was that we use the peertube CLI to install the LDAP plugin. The peertube CLI makes a https call to the app's location. However, it seem hairpin routing does not work on the network. And thus LDAP plugin was not getting installed.

    A workaround was to login as admin and install the LDAP plugin from plugins. Then restart the app.


  • Much appreciated @girish 🙏