Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


SOLVED Uuuh, Nextcloud 20 and lots of problems with encryption


  • everything started with a feedback in the new dashboard "Invalid private key for encryption app. Please update your private key password in your personal settings to recover access to your encrypted files".

    Good news. there is a solution for that -> https://help.nextcloud.com/t/falscher-privater-schluessel-fuer-die-verschluesselungs-app-bitte-aktualisieren-sie-ihren-privaten-schluessel-in-ihren-persoenlichen-einstellungen-um-wieder-zugriff-auf-die-verschluesselten-dateien-zu-erhalten/22659/10 (in german).

    In short: disable encryption app and also in terminal with occ encryption:disable Afterwards enable the encryption app and occ encryption:enable.

    Two people replied with: thank you. thumbs up.
    So I tried.

    But if you are on nc20 (like me), don't do that.
    My current status is perhaps something like https://github.com/nextcloud/server/issues/23302 describes.

    Next OC\ServerNotAvailableException: Could not decrypt key in /app/code/lib/private/Encryption/Keys/Storage.php:287

    An unhandled exception has been thrown:
    Exception: Authenticated ciphertext could not be decoded. in /app/code/lib/private/Security/Crypto.php:122

    Anyone else?


  • Instead of spending more time to find a solution for my non responsive nc-instance, I did a restore of my last backup. To add my findings from the last hours, I cloned the backup first. Then I deactivated the encryption app within nc.
    The stupid user feedback no longer appears.

    For the record. My setting in nc19 was:

    • Default encryption module enabled
    • Server-side encryption disabled

  • Instead of spending more time to find a solution for my non responsive nc-instance, I did a restore of my last backup. To add my findings from the last hours, I cloned the backup first. Then I deactivated the encryption app within nc.
    The stupid user feedback no longer appears.

    For the record. My setting in nc19 was:

    • Default encryption module enabled
    • Server-side encryption disabled