@vladimir Usually for LAMP app, we tend to create separate apps. i.e LAMP 7.3, 7.4 and in the future 8, are totally separate apps. So, your app won't update automatically.

For addons which are shared across apps, we don't have a way to do this. I guess one idea is to have the app "pin" itself to a specific mysql version and that way we will have multiple mysql databases with different versions running in parallel. Doable but quite complicated! I think @luckow also reported that MySQL 8 broke his drupal app.

Good news is that I don't expect such a big upgrade any time soon.