"Error" for multiple apps



  • I'm wondering if the system is missing an necessary kernal...
    I now have 4.4.0-127 and 4.4.0-128

    $ apt list linux-image* --installed
    Listing... Done
    linux-image-4.4.0-127-generic/xenial-updates,xenial-security,now 4.4.0-127.153 amd64 [installed,automatic]
    linux-image-4.4.0-128-generic/xenial-updates,xenial-security,now 4.4.0-128.154 amd64 [installed,automatic]
    linux-image-extra-4.4.0-127-generic/xenial-updates,xenial-security,now 4.4.0-127.153 amd64 [installed,automatic]
    linux-image-extra-4.4.0-128-generic/xenial-updates,xenial-security,now 4.4.0-128.154 amd64 [installed,automatic]
    


  • @uiharu if you cleared the boot issue, just press configure button of an app and press save. The app should come back up.

    If not, can you paste the output of 'docker ps'?



  • Thanks @girish

    I tried again but still get "Error"

    • repair the app
    • restore from the latest backup
    • restore from earlier backups
    • uninstall the app
      but none of the above worked and ended with "Error".

    I also attempted

    • installing an new instance of one of the faulty apps -> "Error"
    • installing a new instance of an app that's not one of the faulty ones -> "Error"
    • Clicking "Backup now" in settings -> "external error"
    [deleted]
    


  • @uiharu thanks, if you click on the app icon usually it will display the full error. Does it not say anything?



  • Actually, please try 'sudo systemctl restart docker' and wait for a minute and then reconfigure an app to see if it changes anything.



  • Unfortunately, the "Error for doamin" overlays are blank (except the buttons)...
    restarting docker...

    [deleted]
    


  • @girish

    The apps still throw "Error" when i attempt to repair/reconfigure them
    Edit: Uninstalling an app also ends with "Error"



  • @uiharu I sent you a mail from support. I think I will need ssh access to debug what is happening. It's most likely something docker related since the cloudron code itself seems to run fine.



  • Looks like this Cloudron hit https://forum.cloudron.io/topic/1316/apps-using-mysql-are-not-working/2. MySQL apps are not working. The workaround is also not working.



  • I forgot to post a follow up on this thread. I'd like to thank @girish for solving my problem. He responded quickly and arranged to ssh into my server to diagnose. He's been very patient and professional and I really appreciate it.

    Basically the problem is due to MySQL addons not properly starting/building, so all apps using MySQL error out and cannot start or install. Hope the problem has been resolved in the final 2.4 releases 🙂


Log in to reply