SMTP Settings for NodeBB - Need confirmation.



  • Hi,
    Here is the settings for SMTP on my NodeBB.
    0_1537877652686_d6d4eebc-7819-4dbc-bf36-591d42d81c1d-image.png

    However, I am not receiving any emails including the confirmation email.
    Is the setting above correct or does it need changing.

    Should the SMTP port be changed to 25 perhaps? and the connection security to StartTLS?

    Thank you for your assistance!



  • Can you first confirm that general email sending from your Cloudron works? You can send out a test email from within the status tab in the email view of your Cloudron dashboard.

    From your screenshot, at least those values look fine. There is no starttls required, since the connection happens on the server local network via port 2525.



  • @jagan is this still an issue for you? Did you confirm that email sending from Cloudron works generally?



  • A bit of thread necro, but I had the same problem. It appears that NodeBB is correctly configured, BUT in the Cloudron portal, by default, the "custom mailbox name" flag in the advanced app configuration settings is set to off. Thus, the email credentials correctly entered into NodeBB led to an account that, by default, was deactivated in Cloudron's mail server.

    For others who stumble here:

    1. From your Cloudron control panel, click the Configure tool (the pencil overlay over the app icon).
    2. In the Advanced tab of the pop-up, ensure that Custom Mailbox Name is checked, and that the name matches the name as configured in NodeBB's email control panel. By default, it's nodebb.app@.

    Problem solved, although whether it immediately resolved or whether it fixed when I rebooted Cloudron to install security updates about three seconds later, well .... 🙂


Log in to reply