Solution to SMTP/IMAP login issues with 3.5



  • Hi all,
    Some of the Cloudrons must have updated to 3.5. If you are hitting some IMAP/email login issues, this post is for you.

    tl;dr - Login with your email/mailbox and not just your username. So, if your Cloudron email is is foobar@domain.com then previously you just logged in with foobar. With Cloudron 3.5, you must login with foobar@domain.com instead.

    Why this change?

    Back in the day, Cloudron only supported one domain. Furthermore, you can only create one mailbox for a user. All this meant that there is a direct 1-1 mapping between username and the mailbox. Over time, we have added multiple domain support and also a single user can have multiple mailboxes. This means that when you login with just the username, we cannot make out which mailbox to open. We had some backward compat code in place which tried to open a default mailbox and this is the reason it has been working for many versions. This backward compat code was removed in 3.5.

    There is no loss of data or email state. Just the login has changed.

    Sorry for the trouble!



  • Sogo login issues

    Some users have reported issues with logging into SOGo even when using the Cloudron email after the update. This is most likely because you are using an older version of SOGo. The old SOGo app was deprecated ~6 months ago as part of the 2.3 release and is not supported. Please move to the new SOGo immediately.

    1. Install the latest version of the SOGo app (from the appstore) in another location/subdomain. You should see your email when logging in with email now.

    2. If you use calendar/contacts in old SOGo, you can migrate it to the new SOGo using the guide at https://cloudron.io/blog/2018-12-05-carddav-caldav-migration.html

    3. If everything is satisfactory, you can just uninstall the old SOGo.


Log in to reply