Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.

SOLVED unable to change own Cloudron password

  • Steps to reproduce:

    1. Log in to your Cloudron
    2. Click your username in the top-right, then "Account"
    3. Click "Change password"
    4. Enter your current password
    5. Paste in "smilingly perky hatbox construct quintet rake shorter zombie remedial prelaunch" (without quotation marks) to "New password" and "Repeat new password"

    Expected result:

    • Password change accepted, no errors displayed

    Actual result:

    • Error message above "New password", "Password must be atleast 8 characters" (NB also missing space)
    • Error message above "Repeat new password", "Passwords don't match"
    • Unable to click "Change"

    It seems that passwords longer than 30 characters are rejected.

    If possible, raising this limit seems like the best option. Otherwise, the message should probably be changed to note that there's a maximum as well as a minimum length.

  • Staff

    @supervacuo Thanks for the report. I have fixed it for the next patch release. The max password length in the backend is 256 but the UI had a bug limiting it to 30.