W3 Total Cache and Redis



  • So I used W3 Total Cache on one wordpress, and I selected Redis for caching (as it was one of the options).

    Nevertheless, my website crashed over time, and looking at the console, I have errors regarding Redis all the time (this one is a sample):

    Feb 12 11:30:40 [Tue Feb 12 11:30:40.186515 2019] [php7:notice] [pid 58] [client 172.18.0.1:41762] Redis server went away
    Feb 12 11:30:40 [Tue Feb 12 11:30:40.188249 2019] [php7:warn] [pid 58] [client 172.18.0.1:41762] PHP Warning: Redis::pconnect(): connect() failed: Connection refused in /app/data/wp-content/plugins/w3-total-cache/Cache_Redis.php on line 351
    

    To be honest, I don't have any idea if Redis is better than the other alternative (Opcode Alternative PHP Cache).



  • @ruihildt The Cloudron Wordpress app does not have redis, so it's not going to work. We can enable opcode cache by default.



  • If it benefits the perfomance, I think that would be great.

    Right now I selected Opcode Cahce, do you mean the setting is currently without any effect? If so I think activating it would be good.



  • opcache is now enabled by default.



  • @girish do I have to update my wordpress, or is it a platform change?



  • @ruihildt It's a wordpress update


Log in to reply