Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.

SOLVED Certificate issues when connecting to IMAP

  • Hi there.
    Today after restarting Cloudron service (it asked about restart due to some security reasons) my mail clients stopped connecting to IMAP with errors related to the SSL certificate.
    I tried to renew certificates through the admin panel but this didn't help.
    Here how it looks from Thunderbird client. First, it says that certificate information is outdated:

    After clicking on Get certificate button it says that it can't get information:

    How can I fix this issue? At the moment I can use email only trough SOGo client.

  • Staff

    @Bounz There is a bug a in Cloudron that when the certificate gets renewed, the mail container is not updated with the new certificate. We are pushing an update in coming days to fix this.

    To workaround:

    1. Go to domains view and add a new domain called (sic) with the No-op provider
    2. Remove the domain

    The above process will update the mail container with the correct certificate. Let me know if that works (or not!)

  • Yes, this did the trick, thank you!

  • Had this happen as well. Thanks for fixing in future versions.