Wordpress Unmanaged (re-directions, unable to install)



  • Hi,
    To have full control on my wordpress installation I selected unmanaged installatoin of wordpress. I want to install it on the main domain i.e http://example.com and not in something like wordpress.example.com

    After installation I saw some error (unable to see it now, installation shows as "running") but when I try to open example.com I get message in browser saying "ERR_TOO_MANY_REDIRECTS".

    I am using cloudflare DNS and in namecheap (where my domain is registered) all nameserver changes are made.

    Please help to resolve this.



  • @realjohny This might just be browser cache issue. Can you try clearing the browser cache for the domain and try? Or try in another browser?



  • @girish Thank you for your response. I tried it in another browser and example.com takes me to wordpress.example.com 🙂

    But when I type www.example.com it gives me error 522 on cloudflare. Also Cloudflare dashboard is giving me a message that my.example.com (my domain) is exposing your real IP. My CNAME record WWW has a value "parkingpage.namecheap.com"

    How can I solve both issues, please help.



  • @realjohny

    • For the my.example.com exposing real IP, you can simply turn on Cloudflare HTTP proxying (i.e click on the cloud icon in cloudflare dashboard to make it become orange). Cloudron will automatically adapt to this change.
    • For the wordpress issue - Delete the www CNAME record in namecheap. Then go to Cloudron dashboard and click on wordpress app's configure button (the wrench icon that appears when you hover over the app). Then in the Location tab, there is a redirections section. Add www there as a redirection. With that done, you will be able to access www.example.com.

    Please let me know if that helped.


Log in to reply