Restoring default security setting



  • I installed firewalld in Ubuntu 18.04. I then removed it.

    Now I am having errors trying to install wordpress app

    here is the error in debug

    server error: (HTTP code 500) server error - driver failed programming external connectivity on endpoint 95c92eae-9ce4-4d12-b61c-b29eee7a5a2c (bdcc609663953b1bd386a347ee9781c62140f856b7deb46c3405b08ce69f5fd3): (iptables failed: iptables --wait -t nat -A DOCKER -p tcp -d 127.0.0.1 --dport 45039 -j DNAT --to-destination 172.18.0.5:8000 ! -i br-05f6896894d2: iptables: No chain/target/match by that name. (exit status 1))



  • @988uh If you reboot the server, the firewall settings should be back. I think the issue is that firewalld overwrites docker's firewall chains. I did a quick search and found https://roosbertl.blogspot.com/2019/06/securing-docker-ports-with-firewalld.html and https://unrouted.io/2017/08/15/docker-firewall/. Do any of those help? For Cloudron itself, you just have to do this to get it's rules back (but I think the issue you are facing is that docker's chains are gone. maybe re-install docker?):

    /home/yellowtent/box/setup/start/cloudron-firewall.sh
    


  • @988uh is there any update on this from your side?


Log in to reply