aBackup failed BadDigest



  • Dear all,

    since some days my automatic backup of Cloudron fails. This is the error message I get:

    Error copying snapshot/app_534a1f46-f14d-4a40-a106-06f7034af7ac.tar.gz : BadDigest BadDigest: The Content-Md5 you specified did not match what we received.
    

    I use a S3 backup server (not AWS) which normally worked fine. Looking at my log-file I saw that the app causing the error was updated when the automatic backup started. The log-file has no message that the update was successful. The app is a nextcloud v4.2.1 but I updated it manually after the error occurred which was successful.
    I think that the problem could be caused by the update while the backup was running so that the file names now don't match. Neither restarting Cloudron nor manual backups help. Is there a way to restart the whole update process or what advice would you give to solve the problem?
    Thank you all 🙂



  • @leon Mm, I haven't seen that error before. For the moment, if you disable automatic backups for NextCloud (under the NextCloud settings -> backups) and then take a full backup.

    After the above, do a manual nextcloud backup using the create backup button in the app's configure UI. Can you send us the resulting logs? (Debug -> Logs) to support@cloudron.io ?

    Also, we have a lock that should prevent the update and backup happening simultaneously. Restarting Cloudron will clear the lock and also stop all the backup/update process (which you tried already).



  • We investigated this offline. The root cause was that the S3 storage service (strato hidrive) does not support multi-part copy. The workaround is to use the rsync format (Backups -> configure -> Format) when you have backups > 5GB.


Log in to reply