Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.



  • Hey folks,

    Anyone aware of the glitch in Rocket Chat since the last update 5 days ago?

    Messages aren't going through and this is what we get from the log

    server.js:204 System ➔ error Error sending message: Error: You are not authorized to change message properties
    Jan 26 16:20:30 at validateUserIdentity (app/lib/server/functions/sendMessage.js:164:9)
    Jan 26 16:20:30 at sendMessage (app/lib/server/functions/sendMessage.js:175:3)
    Jan 26 16:20:30 at executeSendMessage (app/lib/server/methods/sendMessage.js:76:10)
    Jan 26 16:20:30 at MethodInvocation.sendMessage (app/lib/server/methods/sendMessage.js:104:10)
    Jan 26 16:20:30 at maybeAuditArgumentChecks (packages/ddp-server/livedata_server.js:1771:12)
    Jan 26 16:20:30 at DDP._CurrentMethodInvocation.withValue (packages/ddp-server/livedata_server.js:719:19)
    Jan 26 16:20:30 at Meteor.EnvironmentVariable.EVp.withValue (packages/meteor.js:1234:12)
    Jan 26 16:20:30 at DDPServer._CurrentWriteFence.withValue (packages/ddp-server/livedata_server.js:717:46)
    Jan 26 16:20:30 at Meteor.EnvironmentVariable.EVp.withValue (packages/meteor.js:1234:12)
    Jan 26 16:20:30 at Promise (packages/ddp-server/livedata_server.js:715:46)
    Jan 26 16:20:30 at new Promise (<anonymous>)
    Jan 26 16:20:30 at Session.method (packages/ddp-server/livedata_server.js:689:23)
    Jan 26 16:20:30 at packages/ddp-server/livedata_server.js:559:43
    

    Plus some of the admin areas are totally unreadable with symbols instead of letters. As you can see with the 'Accounts' screenshot here:
    rocket-chat-accounts.png

    Anyone with a clue?
    Andy


  • @girish Now it's getting even worse and I'm startled to see no one has even noticed because it seems to be going on for at least 6 days, I've seen a few post about the error we are getting on the RocketChat forum but NO ONE from the staff side has ever replied to any thing.

    I've tried to restore backups up to 4 weeks back and nothing changes (that is weird, does the backup of single app works as intent?)

    Now I'm trying to install a new instance of RocketChat and it's IMPOSSIBLE to install because the setup wizard screen for a totally new instance from the Cloudron Repository appears with WEIRD CHARACTERS, same as the above screenshot I've posted, now what the bip is going on ???

    Andy

  • Staff

    I just setup a new instance and it appears fine here. Also, our chat runs the latest Rocket.Chat and it works fine as well.

    What you are seeing seems to be some font issue. It looks like the page uses Robot Medium. Do you see the same issue on your mobile phone or another PC?


  • My Rocket Chat also running fine

  • Staff

    @micmc do you see this issue on other PCs and browsers as well? Given it kinda looks like a font/charset issue and the restore of quite old backups might indicate this being a client side, not server side issue.


  • @nebulon @girish I should have wait before posting the screenshot because you guys have lost focus on the cause lol ... I cannot tell why all of a sudden the admin UI appears like that in -windoze- (yeah, you're right it was the first thing I thought) in FF and Opera.

    On mobile, I've got disconnected (kicked out) from my server but not yours, as soon as opened the Android client, and I have no more access to the admin from the mobile client so can't tell for now if the font issue would appear.

    However this font-glitch does not appears on my Linux WS, meaning everything looks just fine but the ERROR RochetChat sends on an attempt to message someone and what SHOWS UP in the LOGS at the same time remain, whether on windoze, Linux or with Android client, as I explained at the top of my OP.

    So yeah, clearly it seems like a glitch is -also-maybe- coming from the instance somehow. And of course I noticed that yours works well and so that renders me even more clueless.

    The logs should tell someone something, they are on the server side?

    Meanwhile I will try to install a new instance from my Linux WS and see what happens.

    Andy

  • Staff

    Hi @micmc is this still an issue?