Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


SOLVED Mastodon Terminal not starting


  • Hi, i just installed Mastodon successfully. After i created an user on the running server i tried to add the user the admin functions through the Terminal.

    The Terminal says: 'Connecting...' and 'If you resize the Window press cntrl+D....'.

    After that the screen switches to full black terminal. I have also tried recovery mode but nothing different. I also had a look in the logs but i found nothing..

    Thanks ahead for your help 🙂

  • Staff

    @smilebasti Usually, it will keep saying 'Connecting...' only when the app is not running. Maybe the app was just starting up? Does it say 'Running' in the apps view?


  • @girish Hi thanks for the fast reply.

    Yes the App in running mode.
    It is saying 'connecting...' only for a second or two with the screen size and then is all going black (terminal)

  • Staff

    @smilebasti Do you see this with all apps or just mastodon?


  • @girish This is also with Nextcloud (all other)

  • Staff

    @smilebasti Could be one of two reasons:

    1. docker is not working for whatever reason. Can you check if you can do something like docker exec -ti mysql /bin/bash on the server ? Does it give you a shell? If not, this is a docker issue which we can debug further based on the error message.

    2. Maybe some browser issue. But this seems a bit unlikely. Can you try another browser just in case some extension is causing some problem?


  • @girish Ok the 2. thing is also not working.

    1. your command worked fine.
      Anmerkung 2020-04-06 214445.png
  • Staff

    Can you tail -f /home/yellowtent/platformdata/logs/box.log and see if there is some crash/error when you open the terminal view? Any errors in the browser console?


  • Thats the Error i get when i am starting the terminal

    <I deleted the image because it showed the domain name - girish>


  • This is the chrome console error

    90ffabd6-0d6e-4032-8fd0-95b09922df10-image.png
    website erased

  • Staff

    @smilebasti Indeed, there is a crash in cloudron in quite a strange place. That function should always be defined. Can you send us a mail to support@cloudron.io after enabling ssh access (Support -> enable remote support)?

  • Staff

    OK, we found that the issue was related to having a reverse proxy in front of Cloudron. This reverse proxy was not configured properly to forward web sockets.

    For nginx, we need something like this:

    map $http_upgrade $connection_upgrade {
        default upgrade;
        '' close;
    }
    
    server {
    
        ....
    
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection $connection_upgrade;
        ...
    
    }
    

    For apache, we need something like this:

    
      RewriteEngine on
    
      RewriteCond ${HTTP:Upgrade} websocket [NC]
    
      RewriteCond ${HTTP:Connection} upgrade [NC]
    
      RewriteRule .* "wss:/192.168.20.12/$1" [P,L]
    

    For the moment, one can just use SSH to open a web terminal like this:

    docker ps -f label=fqdn=app.domain.com
    
    docker exec -ti <containerid_from_above> /bin/bash