Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


Error getting IP of mail service



  • Hello,

    I have just tried to turn on the the Income Email function in one of my instance and I get a Cloudron error: "Error getting IP of mail service". None of the DNS are being set-up automatically.

    I don't think I have seen this before in other of my other instances and couldn't find similar problem on the forum or in your doc.

    I am on Wildcard DNS but all apps are being set-up fine and I didn't have this issue on another Cloudron also on wildcard.

    Any idea?

    Thank you



  • @avatar1024 said in Error getting IP of mail service:

    Any idea?

    I think with wildcard set up you'll need to manually configure dns. You should get notifications telling you want needs setting up within 30mins, I think.

    Have you looked at https://cloudron.io/documentation/email/ ?

    (@girish @nebulon I note that page links to https://cloudron.io/documentation/email/#debugging-mail which doesn't seem to exist anymore)


  • Staff

    This error message seems to come from some other part. It tries to get the internal IP address of the mail docker container. Can you check in the system view of the dashboard, if the mail service is running and possibly even just restart it and then re-enable incoming mail again.



  • @nebulon Thank you for the reply. The mail service seem to be running fine, I tried to restart it but that didn't work. I also tried to reboot the whole server, it didn't work either. I am running Cloudron 5.1.3 (and also 5.1.1 and 5.1.2 with same error but didn't try with earlier version) and SMTP works fine, just so you know. Do you want me to contact you via email instead or send you the log of the mail service?

    @jdaviescoates Thank you also. Only DKIM and SPF records you have to setup manually when on wildcard, the other are normally set-up automatically. But also, I don't think I should get that error message in relation to the IP address.


  • Staff

    @avatar1024 This could be because you clicked on 'enable email' too quickly i.e as soon as you created an admin account and clicked on enable email before say 30 seconds to a minute. This can also happen if you did this too quickly after a reboot where the containers are just coming up.

    This happens because Cloudron starts the platform (i.e all the containers for mail/database etc) in the background after the admin account is created. For apps, we have a check for this and it will say "waiting" if you install too quickly. For email, we don't have this check (makes sense to add it).

    Can you confirm if maybe you clicked too quickly? If so, the fix is just to disable incoming mail and re-enable it.

    Also, none of the DNS are setup automatically on wildcard. This is as expected because Cloudron doesn't have access to your DNS.



  • @girish I'm afraid I have enabled and disabled Incoming mail several times already and the first time I did it Cloudron was running for a while so it doesn't seem it's to do with clicking too quickly. Also, just for info, the message also appears when I disable the Incoming email.

    However, I did set all the DNS manually as you pointed out and it seems to all work fine despite the error message about the IP. It's a bit odd but I can live with that as it's not causing any actual issue. Happy to give you ssh access if you want to look into it but don't feel you have to for me.

    @jdaviescoates you were right on the DNS, my memory was wrong! I had set-up a Cloudron with Wilcard a while ago and I didn't remember having to set them all up (btw Gauthier here 😉).

    Thank you all


  • Staff

    OK, I will try to reproduce it locally and reach out if required. Thanks!


Log in to reply