Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


Installation problem during setup - AWS Cloudron AMI



  • Hi,
    I'm trying to setup cloudron using the Cloudron AMI on AWS.
    The server spins up and I'm redirected to the setupdns page as expected. However when I add my details selecting DNS provider AWS Route53 and security credentials I get and error message when I click the 'Next' button. The error is -

    "providerToken must be a non empty string"

    Choosing alternative DNS Providers caused the same error message.

    I've tried on both Firefox and Safari. Chrome doesn't allow me to advance due to the self-signed cert.

    Does anyone have any suggestions?

    Thanks
    Mark


  • Staff

    Hi,

    the AMI on the AWS marketplace require some validation token, which is often the AWS instance id. Usually you should have received a link to the cloudron setup page which has that part added to the link query section. You can add that manually though in your browser url bar by adding https://<ip>/setupdns.html?instanceId=<yourec2instanceid>


  • Staff

    I wonder if I did something wrong with the AMI I published last week. Just spinning up an AMI now to verify but the setup screen should have a provider token field. It won't let you click next without it.


  • Staff

    @markjames Thanks for reporting, this is a regression from our previous release. You can fix this as follows:

    • Edit the file /home/yellowtent/box/src/provision.js
    • Make this change https://git.cloudron.io/cloudron/box/-/commit/1259d1117364715533cb82546abec04987a44f8a . It's just a one liner. All you have to do is to add the line provider: settings.provider() in line 233 in the function getStatus.
    • After that, sudo systemctl restart box (this restarts the code to apply the above change)
    • If you refresh the setup screen, you will now see the AMI owner verification field like this:

    320b6f0a-31e8-4f6d-9eea-651e699e6cdd-image.png

    Let us know if that works, thanks!



  • Thanks, Girish,
    That patch worked. I've successfully setup things.
    cheers
    Mark