Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


www. was not working even after pointing the CNAME to Ghost so I created a redirect in Cloudron



  • Hello Clouron community,

    I did the following just recently:

    413552bd-5679-4cc6-84e4-99ba1d6b1966-image.png

    By doing this, I can now access the www.mydomain.com for my Ghost blog. But, by any chance do you think I'm doing anything incorrectly by approaching it this way? I tried changing the CNAME on Digital Ocean and it wasn't working that way.

    Now if I go to www.mydomain.com (example) the site shows up. It should be fine moving forward, right?

    Sorry this might sound confusing, but the https:// version of the domain has always worked. It's just the www. version that wasn't, though that seems to be fixed, but I wonder what caused this issue?


  • Staff

    This is the correct way to do it. Cloudron in that case will setup the DNS records and also places a redirect to the main location. This is because all apps in Cloudron can only run on a single location, since many of them need one origin for internal use (like sending out emails with backlinks)



  • @nebulon Thank you. So I removed the www. cname record from Digital Ocean and added a www redirect on Cloudron.

    I'm also hoping that I didn't break anything by messing around with all the options and turning things off and on continuously. It should be fine right?


  • Staff

    Yes that should work.


Log in to reply