Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


SOLVED Increase upload max size in Nextcloud



  • I'm getting an error when I try to upload large files (it won't tell me which file is failing so I'm not exactly sure how large) to Nextcloud. I think it has something to do with a general php setting (php.ini) and not something set in Nextcloud itself but I have no experience with php so I'm not sure.

    alt text

    I think if I can get the associated attribute here "Upload max size" to increase it will solve my problem but I don't know how to set it. This is under settings -> administration -> system


  • Staff

    You can edit the htaccess file using the file manager into the app or the /app/data/htaccess file when using the webterminal and add

    php_value upload_max_filesize 10G
    

    to the <IfModule mod_php7.c> section (adjust the 10G to whatever works for your case)

    Then just refresh the browser and you should see the value updated.



  • I think that worked, thanks. By the way, unrelated issue but it looks like the file browser is having trouble. When I go to file manager in Nextcloud config it says "Cloudron error file not found". This apps data was moved to a different disk on the system from the install disk so that might have something to do with it.

    Anyway I added the setting you said using the console and it seems to be working.


  • Staff

    Indeed that is a known bug and you can track that at https://git.cloudron.io/cloudron/box/-/issues/722
    We will fix this hopefully for version 5.5


  • Staff

    This is fixed in 5.5. Should be out late this week or early next week.


Log in to reply